Captive Portal disconnects LAN network



  • I have created a zone on Captive Portal, but when I activate it, even with no authentication, the whole LAN network disconnects.

    A message appears, though: "Don't forget to enable the DHCP server on the captive portal interface! Make sure that the default/maximum DHCP lease time is higher than the hard timeout entered on this page. Also, the DNS Forwarder or Resolver must be enabled for DNS lookups by unauthenticated clients to work."

    What do I have to do?

    I just want to:

    1. Create users to manage my network with permissions and blocks.
    2. And when the users first access, to appear a homepage to insert login/password.


  • @leonardoba780 said in Captive Portal disconnects LAN network:

    I have created a zone on Captive Portal, but when I activate it, even with no authentication, the whole LAN network disconnects.

    That's the way it should work !
    Your captive portal works !

    Now you understand why a captive portal should be activated on a dedicated OPTx interface.
    The LAN interface is reserved for trusted devices only.
    All not trusted devices, those who will be using the captive portal - should use the non trusted interface - the OPTx
    But you can use the captive portal on the LAN interface : think about whitelist some devices.

    @leonardoba780 said in Captive Portal disconnects LAN network:

    A message appears, though: "Don't forget to enable the DHCP server on the captive portal interface! Make sure that the default/maximum DHCP lease time is higher than the hard timeout entered on this page. Also, the DNS Forwarder or Resolver must be enabled for DNS lookups by unauthenticated clients to work."

    Yep, that's true - when you use a dedicated interface it should have a DHCP server and DNS listening on it.
    This is more a generic message, it's true for any interface actually.
    The message exists because people like to 'break thing' : for example, not having a working DNS on the interface will break the portal.

    @leonardoba780 said in Captive Portal disconnects LAN network:

    Create users to manage my network with permissions and blocks.
    And when the users first access, to appear a homepage to insert login/password

    You have a working situation right now on your LAN.
    It's LAN, so DHCP is ok by default.
    If you didn't mess up DNS (change settings in the Resolver) then DNS will be fine also. It's a click - click - click and done manipulation.

    Just simulate a connection : rip out the cable (or cut of the Wifi) - wait 10 sec, and reconnect the cable.

    You will see the captive portal login page as soon as you open a browser -or better : most devices will popup a browser all by itself.
    Your "admin" account and password will be accepted as valid login credentials. Create others in the local user manager.

    See here https://forum.netgate.com/topic/142533/captive-portal-pop-up-not-showing-on-older-android-devices-and-windows-7-devices for a test I did yesterday for testing the captive portal on basic Windows 7 PC's.



  • @Gertjan Sorry, I did what you suggested and also saw your post on the link you put here and nothing worked.

    Do you have any other suggestions for activate Captive Portal on LAN on a simple way?


  • LAYER 8 Netgate

    Add the LAN subnet to the Allowed IP Addresses pass through then enable captive portal. It will be just like you don't have a captive portal which sounds like what you actually want so it's unclear why you are enabling captive portal at all.




Log in to reply