pfSense hinter Fritzbox unter Proxmox möglich ohne extremen Datenverlust?



  • Moin moin,
    habe aktuell eine Fritzbox 7412 im einsatz. Diese geht an einen Switch, woran in der regel 2 clients, ein weiterer Switch in mein Zimmer und zusätzlich der Proxmox Server auf welchem auch die pfSense drauf installiert ist. WAN ist eth0, welches auch die anderen virtuellen maschinen nutzen, welche ich testweise jedoch auch runter genommen hatte ohne besserung bzw. ziehen diese sowieso sehr wenig traffic im idle. Lan geht dabei an eine zusätzliche pcie karte bzw ein eigenes physikalisches Interface besitzt. 3ports sind an der karte auch noch vorhanden, wobei ich diese jedoch noch nicht in benutzung hab bzw. auch in proxmox nicht zugewiesen hab, falls ein extra port als WAN eventuell die lösung sein könnte.
    Könnte mir jedoch vorstellen, dass es auch an doppelten NAT oder allgemein an der fritzbox liegen könnte bzw man sonst die fritzbox komplett weg lassen müsste und sich direkt einwählen oder nen modem vorschalten müssen? Die Fritzbox kann man denk ich mal nicht zum Modem degradieren denk ich mal oder? Habe im Forum von jemanden gelesen, dass es zwar gehen sollen, jedoch ohne erklärung wie und da viele das gegenteil behaupten bzw sagen dass man höchstens PPPoE durchreichen müsste, wodurch jedoch die FritzBox und pfSense gleichzeitig mit dem Provider verbunden wären?

    Aktuell ist der verlust der Daten hinter der pfSense extrem. ping liegt etwa 10-20höher, dl= 20k anstatt von 50 und upload ist sehr unterschiedlich. Youtube geht halbwegs, macht jedoch auch schon starke probleme. Twitch kann man aktuell komplett vergessen und downloads liefen auch teils mit 200-500kb/s. Ich meine das verlust nicht zu vermeiden ist, ist logisch. Aber soviel? Wenn ich ein x beliebigen Router nehme und diesen dran klemme ist der verlust ja auch nicht so extrem bzw teils fast nicht spürbar.... Hab ich irgendwas vllt nicht beachtet und an der pfSense selbst vllt noch nicht gemacht? Aktuell sind noch die standart regeln drinnen, welche ja erstmal alles durch lassen.
    ntopng gibt mir oftmals bzw. bei Twitch z.b eigentlich immer die meldung "tcp connection issues (retransmission ooo lost)" an, falls das helfen kann.

    Ich hoffe dass jemand eine Idee hat, wie man die hohe Latenz und vorallem geringen download eventuell verbessern kann ohne PPPoE durch zu reichen oder die pfSense direkt an ein einzelnes Modem zu hängen. Wenn jemand eine Idee hat, wie man eine FritzBox zu einem Modem degradieren kann, würd ich mich ebenfalls freuen.

    Danke im voraus! :)



  • Hi,

    das klingt, als hättest du die Installationsempfehlungen nicht befolgt:
    Virtualizing pfSense with Proxmox
    Speziell die Sache mit dem "Hardware Checksum Offloading" hätte ich da in Verdacht.

    Bei mir läuft die pfSense virtualisiert auf KVM, auf dessen Basis auch Proxmox arbeitet, alle Netzwerk-Interfaces sind mit virtuellen Bridges verbunden, an denen auch die pfSense Interfaces hängen und das Modem bzw. das Internet ist per PPPoE angebunden. Ich habe damit keinerlei Probleme.
    Zur FritzBox kann ich allerdings nichts sagen.

    Grüße



  • @viragomann
    und so wurden aus ~20k und mega laggs wieder 50k und normale werte... Den Hardware Checksum Offloading hab ich wohl verschlafen. Hätte die Doku wohl zuende lesen sollen und nicht nur den anfangsteil von Proxmox, sondern auch den letzten punkt bzw den checksum :o
    Danke dir jedenfalls sehr! <3



  • Muss zugeben, ich habe es auch erst gelesen, als nix ging im Netzwerk. 😏 Aber verrat mich nicht.



  • @viragomann
    Sehr gut, dann bin ich zumindest nicht ganz alleine damit und durchs nicht zuende lesen, werde ich das ganze Thema mal verschweigen, wenn nicht grad jemand vorm selben problem hockt :D
    Aufjedenfall ein fettes Danke nochmal und erstmal angenehme Ostertage! :)



  • Das problem hat sich wohl leider immer noch nicht ganz erledigt. Die extremen laggs sind nun weg, jedoch hab ich das gefühl das es immernoch eine art loop oder so gibt. Jedenfalls wird es mit der zeit immer langsamer.

    Der aktuelle aufbau ist:
    Fritzbox(192.168.178.1) -> eth0 proxmox -> eth1 proxmox(pfSense LAN= 192.168.1.1) -> switch -> clients
    Auf proxmox ist eine VM mit pfsense, welche halt ebend eth0 als WAN und eth1 als LAN hat.
    Die pfsense ist so ziemlich auf grundeinstellungen, abgesehen von der oben genannten Hardware Checksum Offloading.
    Aktuell erlaubt die pfSense ja noch so ziemlich alles, sodass ich immernoch auf die Fritzbox oder auch andere geräte hinter der Fritzbox komme. Könnt es damit zusammen hängen?



  • Damit es einen Loop geben kann, müssten die beiden NICs des Server irgendwie verbunden sein, z.B. durch ein Gerät, das an beiden Ports hängt, außer der pfSense, natürlich. Das kann außerhalb des Servers oder auch eine VM sein.

    Ist aus den Logs nichts rauszulesen? Im Firewall-Log könnte man asymmetrisches Routing entdecken (das Logging aller Filter-Regeln und das der Default-Regel muss eingeschaltet sein), oder im System-Log, wo Netzwerk- oder Hardwareprobleme zu finden wären.


Log in to reply