Telegraf for ARM systems? (e.g. Netgate SG-3100).



  • Is there any update on this please? =)

    Will we see packages like Telegraf working again on Netgate ARM devices soon?



  • I recently upgraded one of our SG-3100 units to pfSense 2.5.0 (Build from January 1, 2019).

    However, Telegraf still does not appear to be available in the list of packages.

    Is there any idea of when it might be available for ARM-based Netgate devices again?


  • Netgate Administrator

    Our ARM64 build server is now up and running but it looks like it's not yet building Telegraf/Rust etc. I'll see if there's a reason for that.
    No news on ARMv6/7 though.

    Steve



  • Any update on whether Telegraf packages are available for Netgate ARM devices (e.g. SG-3100) yet?


  • Netgate Administrator

    Telegraf is not available for armv6 (SG-3100) for the same reason. It requires a native build because of the language chosen to write it in. We do not currently have any armv6 build hardware so cannot build the package.

    Steve



  • Ah ok - so the build pipeline for Rust/Golang is still not working for the SG-1100/SG-3100 etc, right?

    Do you know if this is likely to be fixed in the future?

    It would be a real bummer if all the SG-1100 and SG-3100 units out there were no longer able to run anything written in Rust or Golang ☹ =(.


  • Netgate Administrator

    The SG-1100 is aarch64 and we do have build hardware for that which is why it has Suricata 5.
    https://twitter.com/NetgateUSA/status/1179190143225417735

    I believe that should allow Telegraph there unless there is another obstacle I'm unaware of (which I might be).

    Steve



  • Aha got it - but the SG-3100 is ARMv6/7, right, so that is still pending?

    Basically, we have around 10 x SG-3100's - and we'd like to get Telegraf (Golang), Suricata (Rust) etc. all working on it.

    Do you know if getting working build support for SG-3100 is on the roadmap?

    Or if the SG-3100 isn't being supported anymore - is there a replacement device on the roadmap? (Although it'd be a bummer if the SG-3100 is being EOLed, since we bought them only last year).


  • Netgate Administrator

    Telegraf is now available on the SG-1100. Please test it if you can.

    We are working on what we can do on armv6.

    Steve



  • I just installed the package on my SG-1100 and in the System Log I get

    Apr 1 00:30:46 kernel pid 72858 (telegraf), jid 0, uid 0: exited on signal 4 (core dumped)

    and when I try and run telegraf from the console I get

    Illegal instruction (core dumped)


  • Netgate Administrator

    Thanks for the report, we are investigating.

    Steve



  • I have a SG-1100 and getting the same results, signal 4 (core dump).


  • Netgate Administrator

    It is still being looked at but is much lower priority than some other things right now.



  • I can confirm it compiles and runs on SG-3100 with the following flags when using telegraf's master and go 1.14.1:

    CGO_ENABLED=0 GOOS=freebsd GOARCH=arm GOARM=7 go build ./cmd/telegraf

    I'm downloading the ports repository now to try and make the package.



  • @stephenw10 I installed the latest Telegraf 0.9_3 package on my SG-1100 today. I'm on pfSense 2.4.5. When I try to start the service I get a continuous stream of core dumps in the system log.

    Apr 19 19:36:18 kernel pid 29205 (telegraf), jid 0, uid 0: exited on signal 4 (core dumped)
    Apr 19 19:36:21 kernel pid 29379 (telegraf), jid 0, uid 0: exited on signal 4 (core dumped)
    Apr 19 19:36:25 kernel pid 29647 (telegraf), jid 0, uid 0: exited on signal 4 (core dumped)


  • Netgate Administrator

    Thanks for the feedback.
    We are are aware of the problems and are looking at it. We are very busy right now though so no ETA I'm afraid.

    Steve



  • @stephenw10 Is there anyway to assist in the progress? I've done lot's of compiling on Linux systems, never on a BSD system, but should be similar after learning the file structure and lib locations.



  • Updated to the 0.9_4 package version, still no joy.



  • i am also waiting for this official release



  • We were going to buy a batch of the 3100's for home users and offices, but knowing it won't support Telegraf is a deal breaker for us and we may have to look at other options now.



  • While we wait for the official plugin. Is there any community documentation I can follow to get telegraf up and running on a SG-3100 without going via the official plugin system?



  • I believe @kamushadenes was trying to make a package before (https://forum.netgate.com/post/904312), I wonder how that went.

    That being said - it would be awesome if the Netgate team was able to get this working again .
    I'm in the same boat as @g0nz0uk - looking to get a couple more SG-3100's - but I want to make sure it's still a support platform.

    Is there a replacement for the SG-3100 (similar pricepoint and capacity) coming out? I'd rather get whatever you have new than buy the SG-3100 and find out it's deprecated.



  • Hi everyone. So the last post in this thread got me thinking. I have a raspberry pi 3b+ laying around it has a A53 (ARMv8) 64-bit processor. I'm wondering if I install FreeBSD on the Pi and then run a clean build of telegraf will it port over? Does anyone see any reason why this wouldn't work? This may get us running on the SG-1100. I'd really like to hear your thoughts before I attempt this.



  • I’ve looked only a little for the FreeBSD source for telegraf with the intention of compiling directly on the SG-1100 then making the binary available for others. Didn’t think about a Pi, or about 7 other SBCs laying around. Not sure how a cross compile on FreeBSD would look, but could be interesting.


  • Netgate Administrator

    I seem to recall suggesting that, or something similar, to our developers when we first saw this issue and it was dismissed as impractical due to the time it would require.
    But if you've got the device and the time then give it a whirl.

    Cross compiling is problem for the dependencies here. I believe GO will not compile using our current setup which is the root of the problem here.

    Steve


Log in to reply