LAN NIC stops passing traffic on Proxmox

  • Hey folks,
    I've been battling this for a while but haven't been able to take the time to write it up and ask for help. Fingers crossed someone may have seen this one before.

    First, I have two nearly identical OVH servers running the same version of Proxmox 5.2.1. One works fine and has like a 300 day uptime. Both have a pfSense VM as the first VM, and both VM configs are identical.

    However, on one of the boxes, the LAN NIC stops passing traffic about once every 12-18 hours. For the NICs, I'm emulating an Intel E1000. I don't get any specific errors, it just stops passing traffic on the LAN interface.

    I have tried using the VirtIO interface, and I get the same result every 12-18 hours, however in that instance, I get a Watchdog error on the interface.

    My solution is to reboot the pfSense instance. I've tried a cronjob every 24 hours, but it's not quite frequent enough. So, about once a day, I have to ssh in and reboot things.

    I dont think it's an issue with the virtual switch in Proxmox because rebooting the VM fixes it. However, it could very well be a Proxmox issue. That said, the other box doesn't have an issue at all and its --pardon the pun --virtually identical.

    Anyone have any troubleshooting tips? (If I could buy negate hardware and ship it to OVH, I'd do that in a second!)

  • Have you disabled hardware offloading on the interfaces?

  • Interesting!
    On my working install, I have all three checked: f

    • checksum
    • TCP segmentation
    • Large Receive

    On the box that breaks daily, I only had:

    • checksum
    • TCP Segmentation

    I ticked the last one to also disable large receive offer. Maybe that will help?

  • I think so.
    On my home installation on KVM with virtIO NIC the network was blocked after each view minutes till I checked "Hardware Checksum Offloading". After checking it there is no issue anymore.
    The other option are the default values anyway.

    It's recommended to disable it in the pfSense docs as well:

Log in to reply