Pfsense reboots after login



  • Hello Everyone,

    I've been using pfsense version 2.3.4-Release-p1.

    The problem is whenever i try to login into web portal the machine get restarted. Yes it get rebooted and the console windows displays many text in a flash of seconds and after that the machine get startup normally.
    If i dont login into portal my networking, vpn & everything get loaded and also works without any error but if i login in the portal again the same problem occurs.
    I've not made any changes in configuration on both software or hardware.
    How can i resolve this issue? will restoring the recent configuration solve it?

    Here is the crash report: http://pasted.co/e3d1605c.

    Any help or suggestion would be appreciated.

    Thanks & Regards,
    Manthan Patel


  • Rebel Alliance Moderator

    That release is old and unsupported. I'd kindly remind you to update to the current and stable version (2.4.4-p2)



  • @manthan2611 said in Pfsense reboots after login:

    How can i resolve this issue? will restoring the recent configuration solve it?

    The console access works ?
    Then see for yourself what happens. For example:
    Use Option 8 and tis command

    clog -f /var/log/nginx.log
    

    Now, try login into the GUI and see what happens. Use a second browser.

    Scan also this one : clog -f /var/log/nginx/error.log


  • Rebel Alliance Developer Netgate

    That is a filesystem error.

    You have two choices:

    1. Reboot into single user mode and run fsck -y / repeatedly until it neither finds nor fixes any errors. Don't stop until you get a completely clean run, otherwise there could still be lingering issues.

    2. Backup the config and reinstall using a current supported version, which would wipe the drive and recreate the filesystem, fixing your problem and getting you up-to-date in one quick action.

    It looks like that should be a 64-bit CPU, so odds are good that it would run 2.4.4, but you can boot from a USB memstick to check. It is a 13-year old CPU so it may be past time to look into replacements, especially if it can't run a 64-bit OS.



  • @Gertjan After triggering that command still had the same problem.

    @jimp have tried 1st method of your's. Had to do it 3 time after that it shows no error then after exiting single user mode booting up properly and login into webGUI worked.

    If the problem arrives again in the future will try your 2nd option.
    For now my problem is been resolved.

    Thanks a lot both of you.



  • @manthan2611 said in Pfsense reboots after login:

    If the problem arrives again ....

    Info : with an UPS which helps pfSense to make a clean shutdown these kind of problems are close to none ...



  • @Gertjan Yeah we will have one from now 😄

    Thanks for your help ;)


Log in to reply