CARP Split-Brain Problem in VMware Umgebung



  • Hallo,

    leider hänge ich auch grad an der CARP Konfiguration.
    Ich habe 2 Nodes als VM auf ESXi 6 am laufen.
    3 Interfaces WAN/LAN/Sync
    Virtuelle IPs auf WAN und LAN (nach Anleitung https://docs.netgate.com/pfsense/en/latest/highavailability/index.html)
    Sync funktioniert
    HA funktioniert nur sauber wenn ich die ganze Node 1 runterfahre oder den LAN oder WAN VMware Netzwerkadapter in den Einstellungen der VM auf nicht verbunden setze. Wenn jedoch nur das LAN oder WAN Kabel vom Host getrennt wird bekomme einen Split - eine Node ist LAN Master und die Andere Node ist WAN Master.

    Nach meinem active/passiv HA Verständniss ist dieses Verhalten völliger Quatsch und nutzlos. Demnach muss ich einen Fehler in der Konfiguration haben.

    Dass ein Link-Down vom Host nicht an die an den vSwitch angeschlossenen VMs durchgereicht wird ist klar und richtig.
    Warum aber nicht alles umgeschaltet wird wenn sich ein CARP Paar nicht mehr sieht verstehe ich nicht.

    An die Empfehlungen bezüglich der vSwitch promiscuous mode konfiguration habe ich mich natürlich gehalten.

    Ich hoffe es kann mir jemand helfen den Fehler zu finden, oder mir erklären (sofern das Verhalten so richtig ist) wie dieses HA in der produktiven Welt funktionieren soll.

    Aktuell funktioniert es in meinen Augen nur wenn: (je eine pfsense Node auf unterschiedlichen ESXi Hosts)

    • Eine VM (Node) fällt komplett aus
    • Ein Host fällt komplett aus
    • LAN Verbindung und WAN Verbindung eines Hosts werden getrennt

    Danke & Gruß
    Br0nch0


  • LAYER 8 Moderator

    Hallo @Br0nch0

    bitte keinen alten Thread ausgraben, nur weil das Problem vielleicht ähnlich erscheint. Hier ist viel zu viel spezifische Info dafür, als das man jetzt nur dein Thema im Auge hat, wenn man hier durchscrollt.

    Ich habe das Thema mal abgetrennt.


Log in to reply