OpenVPN sitio a sitio con router



  • Hola,

    Estamos intentando conectar 2 oficinas remotamente pero es imposible, no encuentro el error.
    En la oficina que hace de servidor tenemos acceso externo con openvpn para empleados.
    El servidor openvpn que creamos tiene puerto 1195, pero despues en las reglas de firewall para ese puerto.

    EN el cliente ponemos nuestro IP publica (no la WAN del fpsense), eso es asi verdad?



  • Sitio server: Pfsense LAN: 192.168.0.1/24 WAN: 192.168.50.2/24
    Router movistar: LAN 192.168.50.1 WAN: miippublica (95...)

    Sitio cliente: Pfsense LAN: 192.168.1.0/24 WAN: 192.168.5.2/24
    Router: LAN 192.168.5.1/24 WAN: miippublica (185...)

    Tengo creado mediante OpenVPN 3 usuarios que se conectan perfectamente al Sitio server.

    Tengo creado tambien otro openvpn server para el tunel :192.168.204.0/30 con sus respectivas reglas en firewall.

    En el cliente he creado tambien el cliente vpn, en el Host de servidor o la dirección tengo puesta la ip publica del Sitio server.

    He creado un NAT outbound en el pfsense del server ya que utilizo el puerto 9874.

    Y no consigo que establezca conexion...

    gracias,
    Mario



  • Consigo que la conexión esté levantada, pero he tenido que poner una regla en el cortafuegos que indica la dirección de origen la ip pública del cliente, eso nose si esta bien. O debería poner una regla con la ip del tunel?

    Y no consigo que ninguna de las 2 lan se vean entre si.



  • Estas son las reglas que tengo en el firewall server:

    firewall server.png

    La ultima regla la ip esa es la ip publica del la parte del cliente.
    En la parte de OpenVPN tengo una regla que acepta todo.

    Tengo levantado el tunel, pero no consio ver niguna maquina del otro lado. Es mas, hago un tracert y la 192.168.204.1 (tunel de la parte del servidor) llega, pero a la 192.168.204.2 (tunel del cliente) no llega, pero en el pfsense aparece como tunel levantando.

    Alguna idea? En el rputer del servidor tengo una regla que los puertos 1194 y 1195 van a la wan del firewall.

    Accedo por openvpn cliente desde fuera sin rpboelmas a la red del servidor.

    A ver si alguno puede ayudarme.

    Gracias,
    Mario



  • Buenos días,

    He conseguido hacer ping desde el cortafuegos a cualquier ip de la LAN, desde el servidor y desde el cliente. Pero de una maquina del server a una maquina del cliente, no tengo respuesta, si tengo respuesta desde el cliente al pfsense del servidor y veceversa.

    Alguien podría ayudarme? gracias.


Log in to reply