[Résolu] pfSense + Haproxy + nextcloud



  • Bonjour à tous,

    Je reviens vers vous, même aux suites de ma conclusion de ce post [Résolu] Nextcloud avec HAProxy et https en "bout en bout".

    Contexte : installation personnel pour la maison, niveau débutant ++

    Besoin : utilisation de regex dans HAProxy

    WAN: j'ai une box SFR 4K fibre en mode bridge sur une VM pfsense

    Packages ajoutés : acme, haproxy, open-vm-tools

    énoncer du problème :
    Mon installation nextcloud est parfaitement fonctionnel, mais dans les tests de configuration de nextcloud, j'ai un problème de redirection pour CalDAV or CardDAV. En effet il est spécifié ici Documentation Nextcloud 16 que cela ne peut pas fonctionner derrière un reverse proxy.

    Solution:
    comme expliquer dans Documentation Nextcloud 16 il est recommandé que cela soit HAProxy qui fasse la redirection. Un exemple est donné mais je suis totalement benêt sur la façon de mettre cela en place.

    Alors si quelqu'un utilise HAProxy avec pfsense et qu'il a une idée de mettre cela en place je suis preneur ☺

    Un grand Merci par avance à tous pour votre aide et une très bonne journée.



  • @visvic
    Try adding it to the advanced textual options?:

    http-request redirect code 301 location /remote.php/dav/ if { path -m reg "^/.well-known/(cal|card)dav" }
    


  • Hello @PiBa ,

    Thanks a lot for your answer.
    do you know how do edit textually? in console ?

    thank a lot.



  • @visvic
    Put the setting in the frontend under "Advanced settings" in the textbox for "Advanced pass thru"



  • Hello @PiBa,

    I have an error when I insert this line in Services/HAProxy/Settings/Global Advanced pass thru

    Here is the error:

    × Errors found while starting haproxy
    [ALERT] 136/120627 (60321) : parsing [/var/etc/haproxy_test/haproxy.cfg:14] : unknown keyword 'http-request' in 'global' section 
    [ALERT] 136/120627 (60321) : Error(s) found in configuration file : /var/etc/haproxy_test/haproxy.cfg 
    [ALERT] 136/120627 (60321) : Fatal errors found in configuration.
    

    And the file generated for test: generate-for-test.txt

    Do you have an idea ?

    thanks again for your help !

    EDIT:
    I found, I was not in the right place. I test because I broke my nextcloud instance.



  • I have same configuration but haproxy is an a VM (not a pfsense plugin).
    I had same error. I have put this line in my haproxy instance at right place and now, error was gone...



  • @visvic
    Put the setting in the frontend



  • @all

    en français merci pour les non anglophone c'est une marque de respect pour ces personnes là.

    merci



  • @Tatave
    Je ne suis pas sûr que vous vouliez dire que je n'aurais pas dû essayer de répondre à une question dans une langue où je ne parle pas / ne comprends pas et ne sais pas écrire. Si c'est le cas, je m'excuse de vouloir aider quelqu'un. J'espère que google-translate fait du bon travail sans gâcher le contexte de ce qui est écrit.



  • Bonsoir @Tatave, @PiBa est déjà très sympa de venir jusqu'à notre langue de Molière pour nous aider, je ne pense pas qu'on puisse lui en vouloir de répondre dans sa langue natal, qui plus est, sera plus précis.
    En revanche, moi j'aurais pu éventuellement faire la réponse en anglais et français.

    @PiBa, thanks again for your good job, I try this very quickly. Merci encore pour ton excellent travail, j'essaie cela très rapidement.

    Bonne soirée @tous 😇
    Good night @all 😇



  • Bonjour à tous,

    La solution de @PiBa a résolu ma demande ! Merci beaucoup à lui pour son intervention.
    @PiBa solution solved my request! Thank you very much to him for his intervention.

    @PiBa said in pfSense + Haproxy + nextcloud:

    @visvic
    Try adding it to the advanced textual options?:

    http-request redirect code 301 location /remote.php/dav/ if { path -m reg "^/.well-known/(cal|card)dav" }
    

    Autre question, est ce que L'en-tête HTTP "X-Frame-Options" à un rapport avec le reverse proxy ?
    another question, does the HTTP header "X-Frame-Options" report to a reverse proxy?

    EDIT: j'ai trouvé ceci X-Frame-Options, @PiBa une idée ? an idea ?

    **EDIT 2:**J'ai renseigné ceci dans le front-end:

    http-response set-header X-Frame-Options "SAMEORIGIN"
    

    et cela fonctionne parfaitement !

    Merci beaucoup à tous et une très bonne soirée :)


Log in to reply