OpenVPN MacOS Limited Connectivity



  • I've got pfSense 2.4.4-p2 running on a Dell R210II. I've got OpenVPN Server configured. From Windows, the OpenVPN GUI is working as expected. From MacOS Mojave (Tunnelblick) and OpenVPN for Android, I'm having issues where some IPs on the server side are pingable, and others aren't. I've got my pfSense box as simply a firewall. I've got a L3 switch on the LAN side with OSPF enabled between the two devices. When connected to VPN, I can ping and access the pfSense device (10.0.14.1) and the L3 switch (10.0.14.2). I can't ping any device on the internal LAN (10.0.0.0/24). But I can ping and access a device (10.0.11.180) off a DMZ interface (10.0.11.0/24) of the pfSense firewall.

    In MacOS I can see a route for the 10/20 network (that is the correct network statement which is entered in the OpenVPN Server config). Here's the output of netstat -nr on the Mac:

    user@MacBook-Pro.local:~$netstat -rn
    Routing tables
    
    Internet:
    Destination        Gateway            Flags        Refs      Use   Netif Expire
    default            10.0.0.1           UGSc           76       41     en0
    10/24              link#5             UCS             3        0     en0      !
    10/20              10.0.15.1          UGSc            2        2   utun3
    ...
    10.0.15/24         10.0.15.2          UGSc            2        0   utun3
    10.0.15.2          10.0.15.2          UH              1        0   utun3
    

    I'm not sure why on Windows this is working fine, but on MacOS it's not. Also, I don't understand why on my Android devices it sometimes does and does not work. Very strange. Any help would be appreciated. Thanks!


  • LAYER 8 Netgate

    Pretty much everyone who uses a Mac and wants OpenVPN to work buys a copy of Viscosity.

    Probably a good time to run a 30-day trial.

    Just sayin'.


Log in to reply