Настройка VLAN



  • Прошу помощи ибо уже задолбался сам :(
    Устанавливаю pfSense в VirtualBox (под VMWare тоже пробовал) под ALT Linux (в Windows 2k3 тоже пробовал). Цель: законнектиться к ADSL и раздать инет по локалке. Что делаю:

    • WAN (em0) - PPPoE,
    • LAN (em1) - 192.168.168.250/24 (локалка),
    • OPT1 (em0) - VLAN10  192.168.0.10/24 (смотрит на ADSL модем).
      LAN работает, WEB-интерфейс доступен, всё можно рулить, все отклично, НО!!! OTP1 не пингуется и сам не пингует модем. Вроде даже и правила пробовал прописывать разрешающие - один фиг.
      Может кто-то описать порядок действий для "системы с нуля" для таких бестолочей, как я?

    ps: pfsense 1.2.2, 1.2.3, 2.0 разнообразные альфа.



  • дык вроде в мануале четка сказано что пинг с OPT интерфейса не поддерживается. Точно строку не скажу, но что это так, уверен.



  • так я ж тогда до модема типа достучаться не могу… ни PPPoE ни до его web морды  ???



  • @Dr.Aleck:

    так я ж тогда до модема типа достучаться не могу… ни PPPoE ни до его web морды  ???

    с сервера нет, подключись любой машиной, как пользователь и достучишься…



  • да, но мне же надо PPPoE установить именно из-под виртуалки, собственно pfsense для этого и ставится.



  • @Dr.Aleck:

    да, но мне же надо PPPoE установить именно из-под виртуалки, собственно pfsense для этого и ставится.

    тогда врядли, по крайней мере мне пока ничего не пришло на ум



  • т.е. изпод виртуалки нельзя подключиться к АДСЛ в режиме бриджа? я правильно понял?  ???  А на реальном железе оно хоть работает????



  • @Dr.Aleck:

    т.е. изпод виртуалки нельзя подключиться к АДСЛ в режиме бриджа? я правильно понял?  ???  А на реальном железе оно хоть работает????

    эм.. а какой ванайпи ты прописал? или у тебя он по dhcp



  • @zar0ku1:

    эм.. а какой ванайпи ты прописал? или у тебя он по dhcp

    WAN? Никакой не прописал, там же PPPoE стоит, что туда прописывать-то еще? А вот на том же интерфейся поднят VLAN -> OPT1 и вот ему уже присвоен 192.168.0.10 (модем 192,168,0,1). См. первый пост.



  • @Dr.Aleck:

    WAN? Никакой не прописал, там же PPPoE стоит, что туда прописывать-то еще? А вот на том же интерфейся поднят VLAN -> OPT1 и вот ему уже присвоен 192.168.0.10 (модем 192,168,0,1). См. первый пост.

    чего-то я тогда недопонимаю, как ты тогда достучишься к вебморде модема, если он у тебя подключен в порт ван, который не имеет айпи адреса?



  • @zar0ku1:

    чего-то я тогда недопонимаю, как ты тогда достучишься к вебморде модема, если он у тебя подключен в порт ван, который не имеет айпи адреса?

    Правильно, именно для таких случаев вроде как рекомендуют поднять еще и vlan на том же интерфейсе, уже с ip



  • хорошо, возможно я купился на неправильную инфу, касаемо развертывания vlan. подскажите, как тогда правильно подключить адсл модем? WAN по-любому должен быть PPPoE, правильно? Как иначе-то? Значит на WAN подцепить IP адрес вручную для доступа к модему я уже не могу. Надо VLAN поднимать. А vlan вместе с OPT1 не пингуют(-ся)



  • @Dr.Aleck:

    Правильно, именно для таких случаев вроде как рекомендуют поднять еще и vlan на том же интерфейсе, уже с ip

    кого-то из нас прет
    у тебя физически интерфейсов на машине 1 или 2?



  • @zar0ku1:

    кого-то из нас прет
    у тебя физически интерфейсов на машине 1 или 2?

    Попробую еще раз. Сетевух физически на машине две (eth0 eth1). В VirtualBox (далее VB) виртуальных сетевух тоже две (pfsense видит их как em0 и em1). Физически на машине: в eth0 (192,168,0,251/24) воткнут модем в режиме бриджа. eth1 (192.168.168.251/24) воткнут в локалку. В VB в pfsense: WAN (em0) - PPPoE (должен получать IP после установки соединения с провайдером). На этом же em0 еще поднят VLAN10 -> OPT1 (192.168.0.10/24) для того, что бы был виден модем. Еще есть LAN (em1) - 192.168.168.250/24 - локалка, в которую должен раздаваться инет и из которой можно рулить pfsense в VB.
    Из локалки LAN (192.168.168.250) пингуется и в WEB-админку pfsense я вхожу. Проблема в том, что pfsense не может установить связь через PPPoE, т.к. он не видит модема. С pfSnese локалка пингуется, а модем нет. И с модема 192,168,0,10 (это который OPT1 в pfSense) тоже не пингуется. Если WAN присвоить IP напрямую (например тот же 192,168,0,10), то модем пингуется, но каким макаром тогда соединение PPPoE установить?
    В общем получается что работают только WAN и LAN, а созданные VLAN не работают.



  • я кажется понял в чем проблема, ты понимаешь что такое влан?



  • @zar0ku1:

    я кажется понял в чем проблема, ты понимаешь что такое влан?

    Ну, судя по тому, что у меня пока ничего не вышло, честно говоря уже не уверен, что понимаю правильно. До этого с VLAN не сталкивался, но немного в инете читал.



  • @Dr.Aleck:

    Ну, судя по тому, что у меня пока ничего не вышло, честно говоря уже не уверен, что понимаю правильно. До этого с VLAN не сталкивался, но немного в инете читал.

    тогда забудь про них, в данном случае они не нужны
    подключаешь в WAN (em0) модем, прописываешь, допустим модем 192.168.1.1 значит у тебя ван 192.168.1.2
    pppoe я бы лучше поднимал на модеме, но тут не суть важно

    потом  в LAN (em1) - 192.168.168.250/24 (локалка), подключаешь кабель от тебя до свича локального, собственно все
    ну еще нужно прописать маршрут что интернет находится за модемом

    все



  • @zar0ku1:

    тогда забудь про них, в данном случае они не нужны
    подключаешь в WAN (em0) модем, прописываешь, допустим модем 192.168.1.1 значит у тебя ван 192.168.1.2
    pppoe я бы лучше поднимал на модеме, но тут не суть важно

    потом  в LAN (em1) - 192.168.168.250/24 (локалка), подключаешь кабель от тебя до свича локального, собственно все
    ну еще нужно прописать маршрут что интернет находится за модемом

    все

    Да, этот вариант я уже опробовал, но надо что бы именно pfsense устанавливал связь PPPoE, а не модем :( А что там с ВЛАН? Сильно сложно получается, да? Или вообще не получится?



  • @Dr.Aleck:

    Да, этот вариант я уже опробовал, но надо что бы именно pfsense устанавливал связь PPPoE, а не модем :( А что там с ВЛАН? Сильно сложно получается, да? Или вообще не получится?

    ну и будет у тебя pppoe на pfsense, в чем проблема?

    ставишь модем в режим моста, втыкаешь в ван, прописываешь в конфигурации ван интерфейса настройки pppoe все
    вланы тебе тут не нужны, у тебя оборудование их поддерживающее есть?

    влан - это логический канал в одном физическом кабеле, используется для того чтобы не тащить 300 кабелей. в твоем случае не нужен



  • @zar0ku1:

    ну и будет у тебя pppoe на pfsense, в чем проблема?

    ставишь модем в режим моста, втыкаешь в ван, прописываешь в конфигурации ван интерфейса настройки pppoe все
    вланы тебе тут не нужны, у тебя оборудование их поддерживающее есть?

    влан - это логический канал в одном физическом кабеле, используется для того чтобы не тащить 300 кабелей. в твоем случае не нужен

    интересный поворот событий… т.е. для того что бы установить соединение через модем (PPPoE - где концовка расшифровывается как over ethernet), мне сам ethernet не нужен? так чтоли? хм... как-то в голову такая мысль не приходила. Не, ну я сейчас попробую конечно... но везде описано что надо подымать opt1 как влан а уже дескать поверх него будет работать wan pppoe/ Например вот http://www.tux.in.ua/articles/679
    "Дело в том, что после установки будут доступны настройки только LAN и WAN. Если с первым все понятно, то что делать с WAN. Если здесь прописать настройки сетевой карты, то тогда, возникает вопрос, где же указывать PPPoE и наоборот. Оказалось сначало следует зайти в меню Interfaces - assign и перейти во вкладку VLANs, где создать новый интерфейс, и возвратиться в “Interface assignments“. После добавления VLAN на этой странице справа появляется неприметная кнопка. Причем эта кнопка служит как для добавления нового интерфейса, если есть свободный VLAN, так и удаления последнего в списке. Поэтому следует быть внимательным. На других вкладках, для удаления и добавления используются разные кнопки. Теперь настройки внешней сетевой карты указываем во VLAN, а в WAN pаполняем информацию о PPPoE. "



  • он у тебя и будет over ethernet (через езернет)
    на pfsense я такое не настраивал, но на freebsd делается так:

    в ppp.conf пишется интерфейс к которому у тебя подключен модем (сам модем бридж)

    -> set device PPPoE:sis0

    ну там же пишешь логин и пароль
    потом запускаешь pppd с нужным конфигом, у тебя создается интерфейс, допустим tun0 с нужным тебе ip

    тоже самое повторяешь на pfsense, чушь про вланы вообще забудь, тут не тот случай, у тебя все банальнее
    ставишь на модеме режим бридж, втыкаешь в ван, прописываешь параметры твоего подключения в настройке ван интерфейса
    сохраняешь, ждешь, смотришь в консоле поднялся интерфейс или нет



  • Для pfSense это простое=стандартное решение. Vlan не для этого случая.

    Таким "Макаром" подключил фою-тую офисов.

    Модем в режиме бридж.

    Interfaces:
    WANGeneral configuration
    Type ->PPPOE и т.д.

    Для экономии трафика, можно подключить SQUID transparent mode.

    Для "полемики", такой маршрутизатор можно поднять и на Вашем модеме, прописав в нём
    PPPOE настройки. Получим то же, но возможностей по настройке меньше.
    Единственные траблы, подключения pfSense PPPTP типа "Корбина".



  • @storma:

    Модем в режиме бридж.
    Interfaces:
    WANGeneral configuration
    Type ->PPPOE и т.д.

    т.е. lan В сетку смотрит, а wan обозначил как PPPoE и просто воткнул модем? Без всяких дополнительных интерфейсов?



  • @Dr.Aleck:

    т.е. lan В сетку смотрит, а wan обозначил как PPPoE и просто воткнул модем? Без всяких дополнительных интерфейсов?

    да



  • @zar0ku1:

    @Dr.Aleck:

    т.е. lan В сетку смотрит, а wan обозначил как PPPoE и просто воткнул модем? Без всяких дополнительных интерфейсов?

    да

    не получается так :(
    Был ли вообще у кого-нибудь опыт развертывания pfsense в виртуалке?



  • @Dr.Aleck:

    не получается так :(
    Был ли вообще у кого-нибудь опыт развертывания pfsense в виртуалке?

    на виртуалке не ставлю такие вещи… не извращаюсь



  • @zar0ku1:

    на виртуалке не ставлю такие вещи… не извращаюсь

    а у меня дефицит техники на работе :( Приходится извращаться… Да и роскошь это: под банальный шлюз целый комп выделать :)



  • тем более существует же pfsense в виде образа для wmvare. Значит это кому0то нужно и даже как-то работает.
    Кстати, может всё же надо vlan поднимать? Про поддержку оборудованием… ну должно вроде как поддерживаться, хоть оно и виртуальное.



  • Все новые версии "тест" в vmware или virtualbox. (А тестить м.. надо обязательно)

    Для примера.
                       VB ver. 2.1.4 / pfSense 1.2.2 built on Thu Jan 8 22:30:24 EST 2009 LiveCD

    Настройки VB:
                           Сеть
                                    Адаптер 1
                                                   Включить сетевой адаптер->True
                                                   Тип адаптера->PCnet-PCI II
                                                    Подсоединён к->Хост-интерфейс

    Кабель подключен->True
                                                    Хост интерфейсы->Atheros Wireless Network Adapter

    Адаптер 2
                                                   Включить сетевой адаптер->True
                                                   Тип адаптера->Inte PRO/1000MT Desktop (8254OEM)
                                                    Подсоединён к->Хост-интерфейс

    Кабель подключен->True
                                                    Хост интерфейсы->Atheros Wireless Network Adapter
                 :Жёсткие диски
                                 IDE первичный шлейв | pfSene.vdi (Обычный, 2.00 GB)



  • Dr.Aleck ты не понимаешь что такое вланы, в твоем случае они не нужны!
    если жалко машину - купи роутер

    P.S. storma выше все верно описал, что там может не работать - для меня большая загадка



  • @zar0ku1:

    Dr.Aleck ты не понимаешь что такое вланы, в твоем случае они не нужны!
    если жалко машину - купи роутер

    P.S. storma выше все верно описал, что там может не работать - для меня большая загадка

    Так я, вроде, и не пытаюсь доказать, что разбираюсь в VLAN :) Наоборот, честно говорю, что не сталкивался с ним.
    Вопрос не в том, что надо решить проблему любыми средствами (віделить отдельно машину, купить роутер и т.п.). Задача вполне конкретная: запустить pfsense в виртуалке и поднять там PPPoE. Пока что это сделать не удается. Ни с VLAN, ни без него. WAN пишет что он UP, но disconnect. Жму connect, но ничего не происходит (хотя вроде бы до модема оно достукивается, т.к. лампочки перемигиваются.) Логин/пароль верен (100 раз перепроверил). Вопрос к storma, что он описал, как у него pfsense работает в виртуалке? Там где-то PPPoE поднят? поому что если нет, то не вижу ценности описаного примера. Просто так у меня тоже работает, но нужен PPPoE.



  • @ToXaNSK:

    Простите, что вмешиваюсь…
    Но зачем вам видеть АДСЛ модем!?
    Раз настроил и забыл.

    У меня 2 роутера на pfSense. На одном 2 инета и локалка, модем АДСЛ, ПППоЕ поднимает pfSense, на втором 1 инет и 2 локалки ПППоЕ тоже поднимает pfSense. Да, тут есть своего рода прикол, что когда ПППоЕ поднимает pfSense, то модем становиться недоступен. Но опять же зачем вам он!?

    Под ВИН2003, видно модем, хотя ПППоЕ поднимает винда, т.е. до него можно достучаться по ИП его. Плюс только один посмотреть скорость соединения и все!?

    Вообщем у меня просто один вопрос зачем его видеть!? Мож мне тоже надо :)

    А ВЛАН всяко не то... ИМХО ::)

    На VLAN я особо не настаиваю - доверяю более продвинутым товарищам :) (обещаю больше даже не пытаться его поднимать)
    Модем мне видеть не принципиально. Я про PPPoE беспокоился, может ему надо :) Не надо? И слава богу.
    PPPoE как-то по особому настраивали? Или только логин/пароль вбили??? Под виртуалкой, случайно, не пытались настроить? ;)



  • Да, сейчас модем работает в режиме бриджа. Шлюз на OpenSuSE. Всё работает. VPI/VCI соотв. вернЫ :)
    Я вот только не пойму, если у тебя PPPoE поднят в pfsense, то почему в модеме PPPoA ???? Там же bridge должно быть.



  • А зачем париться с PPPoE в шлюзе, если можно поднять PPPoE в модеме?  ::)



  • @Mailer:

    А зачем париться с PPPoE в шлюзе, если можно поднять PPPoE в модеме?  ::)

    мы любим придумывать трудности, а потом геройски их преодолевать :)

    ps: на выходных пробовал под виндой, с одной реальной сетевухой подключенной к ADSL и двумя виртуальными (wan и lan). Wan законнектился. Причем последняя 2,0 alpha не пошла, а вот 1.2.2 завелась. Буду сейчас пробовать под линухом.



  • В общем заработал PPPoE. Действительно не пришлось никаких VLAN настраивать. Затык был, почему-то, только в версии 2,0. Поставил 1.2.2 - работает. Обновил до 1.2.3 - работает. Будет время - сделаю бекап и обновлю до 2.0.0 для проверки :) Всем спасибо!



  • по ходу тебе нужен не VLAN а VirtualIP



  • а подробнее?



  • @storma:

    Все новые версии "тест" в vmware или virtualbox. (А тестить м.. надо обязательно)

    Для примера.
                       VB ver. 2.1.4 / pfSense 1.2.2 built on Thu Jan 8 22:30:24 EST 2009 LiveCD

    Настройки VB:
                           Сеть
                                    Адаптер 1
                                                   Включить сетевой адаптер->True
                                                   Тип адаптера->PCnet-PCI II
                                                    Подсоединён к->Хост-интерфейс

    Кабель подключен->True
                                                    Хост интерфейсы->Atheros Wireless Network Adapter

    Адаптер 2
                                                   Включить сетевой адаптер->True
                                                   Тип адаптера->Inte PRO/1000MT Desktop (8254OEM)
                                                    Подсоединён к->Хост-интерфейс

    Кабель подключен->True
                                                    Хост интерфейсы->Atheros Wireless Network Adapter
                 :Жёсткие диски
                                 IDE первичный шлейв | pfSene.vdi (Обычный, 2.00 GB)

    вот все так делаю  виртуальная os не грузится даже - выдает при таких натсройказ ошибку  а если ставить мост то грузится но не видит сеть..
    virtual box под mandriva



  • сидим и разбираемся что такое VLAN тут:
    http://www.xnets.ru/plugins/content/content.php?content.92


Locked