Netflix and Hulu won't stream, Prime video will.



  • I set up my pfsense router last week, and I managed, with the help of the community here, to get it up and running, and get my VPN set up.

    By Friday, I had everything working great. Initially, everyone was blocking me from streaming because of the VPN, but I created an alias and a rule for the "smart" TV and for the fire stick on another TV, so I could bypass the VPN and stream TV over the WAN

    It worked for about 24 hours.

    Now, Netflix and Hulu time out and won't load. I get the "We're having trouble playing this title right now. Please try again later or select a different title." message.

    Oddly, Amazon Prime video works just fine.

    I've tried messing around with different DNS servers, I ran the DNS benchmark test to find the fastest connections, but it doesn't matter.

    I don't know what to try next.



  • mine has worked like this for years with multiple vpn tunnels going

    firewall > rules > lan >
    wan.jpeg !

    services > DHCP server :
    staticdns.jpeg



  • @bcruze

    I tried to copy that idea, but I got this error;

    b143c5b9-1ce7-4385-a3e8-b126214cb8a5-image.png

    What does the static mapping part do? I basically have the same setup in the Firewall rules, except I'm using an Alias rather than the specific device.



  • Static mapping allows you to specify the dns server

    Lower your dhcp pool, or change the tv to its own individual address, then remove it from the alias



  • @bcruze

    OK, I tried all that.

    I excluded the TV from DHCP pool, then did everything else as you suggested, even used Google (8.8.8.8) in the DNS field. The only thing different is I don't have a host name, as the device doesn't seem to have a host name of it's own.

    But in any event, no change. I can stream Prime, can't stream Netflix or Hulu.

    Edit: Just stumbled onto another bit of weirdness. My wife was able to get Hulu working on her phone, which is running through the VPN, so I suspended all the VPN bypass rules for now, and Hulu will now stream, through the VPN on all the TVs in the house.

    Very perplexing now.



  • So I understand : why would specifying another DNS server to device work in this case ?
    Unbound will do what 8.8.8.8 does : resolving - it just takes one more step,

    Netflix, to name an example, doesn't care that you obtained their IP from DNS server A or B ....

    It's know that Netflix uses a 'database' with IP's to where it doesn't stream. Most VPN - if not all - are on that list.

    I never used this myself, but I understood that one need to "policy route" so that some devices do not use the outgoing VPN route.



  • It didn’t sound like it was resolving dns, I’ve seen smart tv do this before. Your right he could have something changed in his resolver Setup...

    This is very unusual

    I created the host name myself just so you know


  • LAYER 8 Global Moderator

    You made sure your not pulling routes from your vpn right? Your not going to want the default to go out your vpn, your going to want to policy route stuff you want to go out the vpn.



  • @johnpoz

    As best as I understand this, I've barred the Client from pulling routes, so nothing should get "sucked in" as it were.

    935e19e1-6652-42e5-8f4a-c46d24ac4e2e-image.png



  • In most cases Netflix is not going to work through the VPN. I would assume the same for Hulu.

    You need to setup policy based routing so that the traffic for the devices you are viewing netflix on are using the WAN gateway. When you setup your firewall rule make sure it's above the rule sending the traffic to the VPN gateway.

    Once you get that working you could work on separating the netflix traffic from the other smart tv traffic with netflix going to the wan and all the other going to the vpn but that's going to be a little complicated, and probably not worth the effort.

    Also, a lot of these smart devices have a dns address hard coded into them. For example, I've tried forwarding DNS traffic from my roku to the forwarder in pfsense and it did not work. I don't recall the exact error but it was related to the connection.



  • @mhertzfeld

    I've already done that, I covered it in my first post. I have an Alias and Rules to send the TV's over WAN, bypassing the VPN.

    f7d47c4a-4b97-4b7b-8842-6437927e7767-image.png

    It would make some sense for these devices to have DNS addresses coded in, otherwise how would they connect, especially over random consumer setups which they can't predict? I don't see how that would be a problem though, considering these devices work just fine on my consumer router, and even worked for a day with my setup on pfsense, so whatever DNS address it's using, it's fine. The problem isn't the television AND the Firestick, that would be a coincidence, and like Dr. House, I don't believe in coincidences.



  • For what it's worth, I think I've completely ruled out the VPN. If I disable all the firewall rules, I have the same issues with Netflix and Hulu not streaming. I look at the traffic graph and it just looks like it's not even trying. But Prime works fine, the internet at large works fine, I streamed videos from YouTube all day today (through VPN) though I just tested it and it'll stream YouTube just fine without the VPN rules active.



  • When you stream does it stop because it’s detecting a proxy?

    Can you view the Netflix initial screen and tap your account when you open it?

    Your gonna have to post some screen shots of your config other wise we are all just pointing and guessing / working blindly



  • @bcruze

    When I run it through the VPN, yes. When I bypass the VPN, no.

    Nobody has asked for screenshots yet, so what do you want to see?

    This?

    da6e2712-f763-4731-a29e-50c9668963d9-image.png

    This?

    44e1328f-4745-42b8-8656-2139edfb6743-image.png

    That?

    a17699c6-b8e3-4920-9243-1cdf3a072550-image.png

    Thus?

    5f746f9c-761a-499f-8c87-fba6a841cf48-image.png

    Other?



  • Maybe post some pics of your unbound settings.

    Are you doing DNS redirecting? From your posts it doesn't sound like you are but I know some of the guides for setting up VPN client include the steps for redirecting DNS and sending the requests over the VPN.



  • @mhertzfeld

    I'm not sure what an unbound setting is, so I'm going to have to assume it's set to default, or I just don't understand what you mean.

    Basically, everything is default, other than what the NordVPN guide said to do, plus some extra steps for setting up the alias/Rules to allow specific devices to bypass the VPN.

    I haven't had a chance to get any further into personalizing my pfsense setup, and do stuff like add packages, or shape traffic, or monitor or anything, because I'm still trying to get through the metaphorical front door. The setting up of the VPN was the first "unique" thing I've tried, and I'm think I've got that part working, but something else, besides the VPN is giving me issues.

    Edit:

    I'll take my best stab at it, based on the NordVPN guide, this stuff?

    8f0344cb-a5c7-497a-8071-cdc1849cbb7a-image.png



  • The resolver screen shot is what I was looking for, you got it. Can you post your Port Forward screen as well to see if you are doing any redirecting?

    For troubleshooting I would recommend reverting the settings in the resolver back to their defaults. Or at a minimum I would set the outgoing network interface to WAN.

    As an alternative to using the VPN for your DNS traffic you could do DNS over TLS to cloudflare or quad9. That should keep your ISP from snooping on your DNS queries and you would still be able to resolve DNS if your VPN went offline for some reason.



  • @mhertzfeld

    This one?

    04027320-aa3e-4c5a-a9b4-a2aa7db7ec47-image.png



  • That helps but what I was asking for is under firewall\nat\port forward.



  • @mhertzfeld

    Oh I haven't done anything in there, it's empty.

    6924b549-b513-4763-9258-1a16603eddbc-image.png

    OK, so I'm gonna try the troubleshooting bit you mentioned. I'll try setting outbound to WAN



  • OK then, it's working. Changing that to WAN works.

    Does this mean the VPN is now being fully bypassed by everything? Or do the rules/aliases still count?



  • Switching the Outgoing Network Interface setting to WAN means that the DNS query traffic from your DNS resolver in pfsense will go through your WAN interface, where before it was going through your VPN.

    All your host traffic should be going through which ever gateway you configured in your firewall rules. So if I remember your setup correctly, all the traffic in that alias should use the WAN and everything else uses the VPN.

    Netflix wasn't working because of some sophisticated systems they setup to detect if users are using a VPN or some sort of other mechanism to get around their geo blocks. DNS is part of that, but I don't have time to explain right now.



  • d5cc103f-5982-42b6-adb5-eeb94b28c82c-image.png

    That's the Forwarder.
    As the image stated, it's deactivated.

    The Resolver ?


  • Banned

    This post is deleted!

Log in to reply