Not getting a wan address after vlan tagging the connection from switch to esxi 6.7



  • Hey peeps,

    im trying to setup a virtual pfsense on ESXI 6.7 without using a dedicated line to my modem. i want to be able to use a VLAN so i can create multiple pfsense's or use HA in Vcenter
    my ISP doesnt need me to assign a vlan tag for my wan.
    my modem is on bridge mode and is connected to port 12 on my switch, with PVID 90 and untagged.
    on my Lag to the server the vlan 90 is tagged.
    in vcenter i created a d-switch with promiscuous mode on, mac address changes on and forged transmits on.
    in esxi i allowed all 4095 vlans.
    i tried e1000 nics, and i first setup pfsense using just the nic as wan, then afterwards i created a vlan 90 in pfsense and assigned it to the wan, still didnt work.
    i read somewhere that you need to link the nic to another interface. so i added em0 to opt1 and just enabled it.
    am i missing anything ?


Log in to reply