Linux VMs have no DNS while Windows VMs do



  • Hi,

    I installed pfsense 2.4.4-RELEASE-p3 on Proxmox and connected a few VMs to its LAN ports via virtual bridge. What's weird is that all my windows VMs can properly get the DNS settings from DHCP server but none of the Linux VMs have working DNS. In linux VM I am able to ping both internal and public ip address which means i have internet access, but pinging google.com shows "Temporary failure in name resolution."

    I have read a thread about a similar problem and people saying changing the network device model type from VirtIO to E1000 or RTL but it's not working in my case.

    I also tried setting static ip, gateway and DNS manually in /etc/network/interface but still couldn't get it to work. Any advice would be much appreciated!



  • What flavour & version of Linux? Some distros require you to edit /etc/resolv.conf for DNS settings.



  • Like @KOM said, most Linux flavours use /etc/resolv.conf for DNS resolution. You can manually set a static DNS entry in there by specifying the correct nameserver as the pfSense box. chattr +i /etc/resolv.conf should prevent changes to it being made on reboot.


Log in to reply