pfsense blocking discord app connectivity

  • so, I have pfsense properly configured as a default deny all unless otherwise specified, and I am unable to find anything, that I have been able to successfully use to get the desktop discord client to connect, at all, and am at a loss here so I figured I'd just come to the experts, and ask directly!

    I have found, that discord states it needs to be able to connect on port 443 (https) for access to connect, and I allowed that, on the case of udp AND tcp, to and to no change, so I'm at a complete loss, and have not had enough sleep to understand why this is not working.

    my pfsense firewall has the following services in total, and I'll list which ones are enabled and disabled respectively.

    bandwidthd (enabled)
    c-Icap (enabled)
    clamd (enabled)
    darkstat (enabled)
    dhcpd (enabled)
    dpinger (enabled)
    iperf (not yet enabled)
    named (enabled)
    ntopng (enabled)
    ntpd (enabled)
    pfb_dnsbl (disabled until I can fix the issues its causing, namely and originally THIS being why discord would not connect, no longer seeming to be why it wont)
    pfb_filter (disabled, ditto above)
    squid (enabled)
    squidguard (disabled currently, plan to enable again)
    suricata (enabled)
    syslogd (enabled)
    tinc (not yet configured to be able to enable it)
    unbound (enabled)

    any log data, or additional info available upon request if it would be useful to provide (I would not know WHAT to provide at the moment to provide it proactively)

    I would like to know what I need to do, to enable my ability to connect and use discord THROUGH my firewall, else what is the point of having one if I have to bypass its additional security just to use one of the primary applications I need to use for the work that I do with friends of mine. I will work on this for as long as it takes to get this working and fixed, and also be able to provide documentation for others like me that are having this same issue, given how little I was able to find online at all for documented steps to fix this issue.

    Thank you for your time!

Log in to reply