Connection does not complete.



  • Hi , We have been using OpenVPN for quite a while. Every time we add a user, create a certificate, send the user a Windows client to install, we have had no problem. Everything works and an OpenVPN session is made with no problem. The last two users created they have not been able to make a connection. In the complete log below for the session connection effort it is this section that is identical for both users for where the error seems to occur.
    "Wed Jun 26 10:59:19 2019 Warning: route gateway is not reachable on any active network adapters: 192.168.10.1
    Wed Jun 26 10:59:19 2019 env_block: add PATH=C:\Windows\System32;C:\Windows;C:\Windows\System32\Wbem
    Wed Jun 26 10:59:19 2019 Warning: route gateway is not reachable on any active network adapters: 192.168.10.1
    Wed Jun 26 10:59:19 2019 env_block: add PATH=C:\Windows\System32;C:\Windows;C:\Windows\System32\Wbem"

    In both instances the route gateway IP address that it is referring to is the user's default gateway on their home network. The interesting thing is this is only happening on their laptops issued by our employer. If they try a connection from their own personal computer or laptop there is no problem. The odd thing is the rest of us use our employee issued laptops and have no problem. It seems that something must have recently changed on our employer's image for the laptop but I have no idea what?

    Complete log below.

    Wed Jun 26 10:58:31 2019 Warning: cryptapicert used, setting maximum TLS version to 1.1.
    Wed Jun 26 10:58:31 2019 OpenVPN 2.4.4 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Sep 26 2017
    Wed Jun 26 10:58:31 2019 Windows version 6.2 (Windows 8 or greater) 64bit
    Wed Jun 26 10:58:31 2019 library versions: OpenSSL 1.0.2l 25 May 2017, LZO 2.10
    Enter Management Password:
    Wed Jun 26 10:58:39 2019 TCP/UDP: Preserving recently used remote address: [AF_INET]96.70.160.187:1194
    Wed Jun 26 10:58:39 2019 UDP link local (bound): [AF_INET][undef]:1194
    Wed Jun 26 10:58:39 2019 UDP link remote: [AF_INET]96.70.160.187:1194
    Wed Jun 26 10:58:39 2019 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
    Wed Jun 26 10:58:40 2019 [vpn.cswp.local] Peer Connection Initiated with [AF_INET]96.70.160.187:1194
    Wed Jun 26 10:58:41 2019 open_tun
    Wed Jun 26 10:58:41 2019 TAP-WIN32 device [Ethernet 4] opened: \.\Global{5DD663F6-8E68-4C99-8018-4C821F314CA6}.tap
    Wed Jun 26 10:58:41 2019 Set TAP-Windows TUN subnet mode network/local/netmask = 192.168.10.0/192.168.10.8/255.255.255.192 [SUCCEEDED]
    Wed Jun 26 10:58:41 2019 Notified TAP-Windows driver to set a DHCP IP/netmask of 192.168.10.8/255.255.255.192 on interface {5DD663F6-8E68-4C99-8018-4C821F314CA6} [DHCP-serv: 192.168.10.62, lease-time: 31536000]
    Wed Jun 26 10:58:41 2019 Sleeping for 3 seconds...
    Wed Jun 26 10:58:44 2019 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
    Wed Jun 26 10:59:19 2019 Warning: route gateway is not reachable on any active network adapters: 192.168.10.1
    Wed Jun 26 10:59:19 2019 env_block: add PATH=C:\Windows\System32;C:\Windows;C:\Windows\System32\Wbem
    Wed Jun 26 10:59:19 2019 Warning: route gateway is not reachable on any active network adapters: 192.168.10.1
    Wed Jun 26 10:59:19 2019 env_block: add PATH=C:\Windows\System32;C:\Windows;C:\Windows\System32\Wbem
    SYSTEM ROUTING TABLE
    0.0.0.0 0.0.0.0 192.168.1.1 p=0 i=26 t=4 pr=3 a=2247 h=0 m=25/0/0/0/0
    0.0.0.0 128.0.0.0 192.168.10.1 p=0 i=26 t=4 pr=3 a=0 h=0 m=26/0/0/0/0
    96.70.160.187 255.255.255.255 192.168.1.1 p=0 i=26 t=4 pr=3 a=0 h=0 m=25/0/0/0/0
    127.0.0.0 255.0.0.0 127.0.0.1 p=0 i=1 t=3 pr=2 a=2257 h=0 m=331/0/0/0/0
    127.0.0.1 255.255.255.255 127.0.0.1 p=0 i=1 t=3 pr=2 a=2257 h=0 m=331/0/0/0/0
    127.255.255.255 255.255.255.255 127.0.0.1 p=0 i=1 t=3 pr=2 a=2257 h=0 m=331/0/0/0/0
    128.0.0.0 128.0.0.0 192.168.10.1 p=0 i=26 t=4 pr=3 a=0 h=0 m=26/0/0/0/0
    192.168.1.0 255.255.255.0 192.168.1.81 p=0 i=26 t=3 pr=2 a=2247 h=0 m=281/0/0/0/0
    192.168.1.81 255.255.255.255 192.168.1.81 p=0 i=26 t=3 pr=2 a=2247 h=0 m=281/0/0/0/0
    192.168.1.255 255.255.255.255 192.168.1.81 p=0 i=26 t=3 pr=2 a=2247 h=0 m=281/0/0/0/0
    224.0.0.0 240.0.0.0 127.0.0.1 p=0 i=1 t=3 pr=2 a=2257 h=0 m=331/0/0/0/0
    224.0.0.0 240.0.0.0 192.168.1.81 p=0 i=26 t=3 pr=2 a=2251 h=0 m=281/0/0/0/0
    255.255.255.255 255.255.255.255 127.0.0.1 p=0 i=1 t=3 pr=2 a=2257 h=0 m=331/0/0/0/0
    255.255.255.255 255.255.255.255 192.168.1.81 p=0 i=26 t=3 pr=2 a=2251 h=0 m=281/0/0/0/0
    SYSTEM ADAPTER LIST
    Intel(R) Ethernet Connection (4) I219-LM
    Index = 26
    GUID = {EED1D0D2-CA8D-41E7-AF07-D46E351BBB79}
    IP = 192.168.1.81/255.255.255.0
    MAC = 10:65:30:82:bd:62
    GATEWAY = 192.168.1.1/255.255.255.255
    DHCP SERV = 192.168.1.1/255.255.255.255
    DHCP LEASE OBTAINED = Wed Jun 26 10:21:52 2019
    DHCP LEASE EXPIRES = Thu Jun 27 10:21:52 2019
    DNS SERV = 192.168.1.1/255.255.255.255
    Bluetooth Device (Personal Area Network)
    Index = 13
    GUID = {5BBC9FBA-7748-47DC-900F-0806C542E68C}
    IP = 0.0.0.0/0.0.0.0
    MAC = 20:16:b9:5e:cd:d2
    GATEWAY = 0.0.0.0/255.255.255.255
    DHCP SERV =
    DHCP LEASE OBTAINED = Wed Jun 26 10:59:19 2019
    DHCP LEASE EXPIRES = Wed Jun 26 10:59:19 2019
    DNS SERV =
    Juniper Network Connect Virtual Adapter
    Index = 25
    GUID = {EC4150E8-A716-4185-A630-4D73014F1B16}
    IP = 0.0.0.0/0.0.0.0
    MAC = 00:ff:b0:db:79:94
    GATEWAY = 0.0.0.0/255.255.255.255
    DHCP SERV =
    DHCP LEASE OBTAINED = Wed Jun 26 10:59:19 2019
    DHCP LEASE EXPIRES = Wed Jun 26 10:59:19 2019
    DNS SERV =
    Fortinet Virtual Ethernet Adapter (NDIS 6.30)
    Index = 5
    GUID = {190FA6F9-2A0E-40C7-9DC6-ACCC11432DE4}
    IP = 0.0.0.0/0.0.0.0
    MAC = 00:09:0f:fe:00:01
    GATEWAY = 0.0.0.0/255.255.255.255
    DHCP SERV =
    DHCP LEASE OBTAINED = Wed Jun 26 10:59:19 2019
    DHCP LEASE EXPIRES = Wed Jun 26 10:59:19 2019
    DNS SERV =
    Intel(R) Dual Band Wireless-AC 8265
    Index = 27
    GUID = {F93304BC-0106-4126-8B4D-BFC6501C0A46}
    IP = 0.0.0.0/0.0.0.0
    MAC = 20:16:b9:5e:cd:ce
    GATEWAY = 0.0.0.0/255.255.255.255
    DHCP SERV =
    DHCP LEASE OBTAINED = Wed Jun 26 10:59:19 2019
    DHCP LEASE EXPIRES = Wed Jun 26 10:59:19 2019
    DNS SERV =
    Microsoft Wi-Fi Direct Virtual Adapter
    Index = 9
    GUID = {3AD45C6A-1D33-474E-A137-BC5B138B763F}
    IP = 0.0.0.0/0.0.0.0
    MAC = 20:16:b9:5e:cd:cf
    GATEWAY = 0.0.0.0/255.255.255.255
    DHCP SERV =
    DHCP LEASE OBTAINED = Wed Jun 26 10:59:19 2019
    DHCP LEASE EXPIRES = Wed Jun 26 10:59:19 2019
    DNS SERV =
    Microsoft Wi-Fi Direct Virtual Adapter #2
    Index = 6
    GUID = {212BAFDA-23A9-4EAE-AE73-4A93C2E62932}
    IP = 0.0.0.0/0.0.0.0
    MAC = 22:16:b9:5e:cd:ce
    GATEWAY = 0.0.0.0/255.255.255.255
    DHCP SERV =
    DHCP LEASE OBTAINED = Wed Jun 26 10:59:19 2019
    DHCP LEASE EXPIRES = Wed Jun 26 10:59:19 2019
    DNS SERV =
    Wed Jun 26 10:59:19 2019 Initialization Sequence Completed With Errors ( see http://openvpn.net/faq.html#dhcpclientserv )



  • So what I discovered is that the no protocols are being set (checked) for the TAP-Windows Adapter during installation of the OpenVPN client. Why would that all of a sudden change when nothing else changed from the OpenVPN end? Still using same process. Still using same version of client, etc.


Log in to reply