OpenVPN Authentication error



  • Hi !

    pfSense was using its local user database and the LDAP connection to the Active Directory server before I activated OpenVPN with TLS/SSL + User authentication.

    The first connection from a client worked well, but after changes to the configuration (unfortunately I can not tell what was changed), the client always received an authentication error (user for OpenVPN was one of the local database).

    I tried several changes (removed the LDAP server, changes in server and client settings) before I came up with the idea to change the server mode to "Remote access (TLS/SSL)" and then back to "Remote access (TLS/SSL + User auth)" - and suddenly it all worked fine again !

    So it seems that some configuration changes are not entered correctly in the configuration file underneath - which finally was corrected by doing the mentioned changes.

    Hope this helps someone else in case of trouble with the authentication in OpenVPN !


Log in to reply