help with wan static address



  • Good afternoon,

    I'm new here, I've been studying a lot these days and I've made a lot of progress.
    I'm configuring my WAN in pfsense with static ip, but it does not work as expected.

    I changed the WAN settings this way:
    Static IPv4
    Disable IPv6
    Ip: 177.xx.xx.90
    And I added a new Gateway 177.xx.xx.89
    The mask provided by my ISP is 255.255.255.252, so I used / 30 I tried it too / 24

    The network card flashes slowly.
    When accessing the status interface it stays: no carrier

    These same settings on an ordinary router work normally.
    Another class of ip also worked ...
    If I provide another address on this network card it works, then this is not the problem ...
    Anyone know what it could be?

    appreciate


  • LAYER 8 Moderator

    @Galbiere said in help with wan static address:

    When accessing the status interface it stays: no carrier

    No carrier means that - that interface has no connection to anything or the cable is faulty.



  • @JeGr thanks for answering

    is exactly that the problem, if I put this same cable on an ordinary router it works normally.
    I tested it on another UTM and another router recently, strange as it sounds in pfsense does not recognize, but on other platforms it works, alias, I'm using it now



  • Hi @JeGr how are you?

    After much research I discovered the reason for my failure.
    In the WAN interface I selected in Speed ​​and Duplex the autoselect option. This caused the firewall to recognize the connection and identified it as
    <10baseT / UTP <full duplex, flowcontrol, rxpause, txpause>

    Problem solved.

    Thank you


  • LAYER 8 Moderator

    Fine thanks, nice to hear back. Also autoselect is the default when setting up an interface so that should have been the case for you, too. So if you configured it manually no wonder it failed the auto-negotiating and thus reported no L2 carrier :)

    But good for you that it worked out and you found it! Just let it on auto-negotiating the next time ;)


Log in to reply