Can't ping Windows 10 machine



  • Hello,

    I recently started playing with pfsense and set up a testing environment. I got the sense running on a SuperMicro board with an Intel Atom C2758 and 4 Network ports. The WAN port is connected by PPPoE, and I got a couple of switches behind the LAN Port.
    While setting up different VLANs and corresponding firewall rules, I had troubles with pinging between the test clients. After trying different setups, I figured out that my problem only consisted while sending a ping from a Linux to a Windows 10 machine.
    So I broke everything down (to get switches, firewall rules, etc. out of the equation) to the basics and connected the Windows client directly to the LAN port of the pfsense. On the machine itself, I started different virtual machines which could communicate with each other with the following result:
    Windows ping Windows -> OK
    Windows ping Linux -> OK
    Linux ping Linux -> OK
    Linux ping Windows -> no response
    Linux access Web server on Windows ->OK

    I tried a different Windows 10 machine and also different instances running Debian, Ubuntu, and CentOS. I also couldn’t ping the Windows Machine from the Interface of the sense, while accessing the interface from this machine. What really drives me crazy is that I can start a Web server on the Windows machine and open the Page from every Linux system by the Host IP address an still get no response pinging the same IP.

    Is there some Setting in pfsense I missed that could cause this issue?


  • Banned

    @William_von_Baserville said in Can't ping Windows 10 machine:

    Is there some Setting in pfsense I missed that could cause this issue?

    As always: Check the Windows firewall settings. By default they only allow pings from the local subnet. Also learn the basics about the operating systems you use.


Log in to reply