OpenVPN Iterface



  • Hello all, I don't know exactly when this started to happen, but in the past I had a Interface called "VPN" bound to the OpenVPN Interface, and with this I was able to define the rules and use the vpn in packages. Now I don't know way, all my rules on the created "VPN" interface are ignored and the triffic is flowing by the OpenVPN Interface!

    Some Images to help

    The deffenition of the VPN Interface
    b0cd0db5-08a2-472d-bc5f-d5b81f2a3018-image.png

    The Rules In the VPN Interface (Please note the second rule description)
    cb75315f-c363-4c0e-8da9-6c519d585c41-image.png

    The Rules in the OpenVPN Interface (Please note the second rule description)
    07235adc-177b-40d4-a16d-95d41d2ed4f8-image.png

    The Log
    d977edd7-c70e-45c3-a411-3408c7dc0f74-image.png

    Note that the interface is the "VPN" but the rule that is interpreted is the one from "OpenVPN" Interface. I know that in the past this was not the case, I had the "OpenVPN" interface without any rule, but I had to copy them from the "VPN" interface to keep them working. At the moment the rules from the "VPN" interface are all ignored.

    Any one noticed this? Is this normal?

    Thank you


  • LAYER 8 Netgate

    The rules on OpenVPN are processed before rules on the assigned interface tab. If traffic is passed by those rules, the interface rules are never consulted.



  • If I remove the rules from the OpenVPN interface I lose all access when under the vpn! The rules on the VPN interface are never analyzed


  • LAYER 8 Netgate

    Then you are doing it wrong. Not sure what else to tell you. Post your config screens.

    You are trying to match traffic sourced from VPN Net. Chances are that is not matching anything. Try changing those sources to any (like they are on the OpenVPN tab.)


Log in to reply