SG-1100 upgrade issue with 2.5.0.a.20190711.1719



  • I cannot seem to upgrade my SG-1100 from the GUI or console. I get the following message when updating from console:

    >>> Updating repositories metadata...
    Updating pfSense-core repository catalogue...
    1081909248:error:141F0006:SSL routines:tls_construct_cert_verify:EVP lib:/usr/local/poudriere/jails/pfSense_factory-master_aarch64/usr/src/crypto/openssl/ssl/statem/statem_lib.c:273:
    1081909248:error:141F0006:SSL routines:tls_construct_cert_verify:EVP lib:/usr/local/poudriere/jails/pfSense_factory-master_aarch64/usr/src/crypto/openssl/ssl/statem/statem_lib.c:273:
    pkg-static: https://repo.netgate.com/beta/packages/pfSense_factory-master_aarch64-core/meta.txz: Authentication error
    repository pfSense-core has no meta file, using default settings
    Child process pid=34640 terminated abnormally: Bus error
    

    I also get the following when running "pkg update" from the shell:

    Updating pfSense-core repository catalogue...
    1076527104:error:141F0006:SSL routines:tls_construct_cert_verify:EVP lib:/build/factory-crossbuild-master/pfSense/tmp/FreeBSD-src/crypto/openssl/ssl/statem/statem_lib.c:273:
    1076527104:error:141F0006:SSL routines:tls_construct_cert_verify:EVP lib:/build/factory-crossbuild-master/pfSense/tmp/FreeBSD-src/crypto/openssl/ssl/statem/statem_lib.c:273:
    Child process pid=72382 terminated abnormally: Segmentation fault
    

    I am wondering if this is a known issue with this development version?


  • Rebel Alliance Developer Netgate

    Not a known issue I'm aware of, but there are other issues with 2.5 on the 1100. I thought we had blocked it from moving up to 2.5 until we fixed a few more things there.

    You might try a clean image of 2.4.4-p3 and then see if you can upgrade from there. I wouldn't trust 2.5 for much on that until it progresses further.



  • No worries, I will go back to the 2.4.4-p2 ( that is the netgate image I already have ), then get to 2.4.4-p3. I was testing a few things with 2.5, I have no need to be on it any longer. I had planned on going back to 2.4.4, this just moved it up on the list.

    Thanks for the reply.


Log in to reply