Problem with Wless and DHCP


  • Hello,

    Alix/pfsense 1.2.2 embedded

    I have a problem with my wless.

    I bridged LAN and WLESS, added wless rule: * Wless net ****

    I see my wless network but I'm unable to obtain a ip adress from the dhcp server (working fine from the wired LAN…)

    I saw: http://forum.pfsense.org/index.php/topic,11309.0.html

    but I don't understand what I'm supposed to do (and the post is for an old version)

    Thank you!


  • Change the rule to * LAN subnet ****
    (since there actually is no "wless subnet")


  • Hello!

    thank you for the quick answer!

    I did that and rebooted pfsense but…. still not working :-(


  • Ewerything works fine if I manually assign an ip/gateway/etc… adress...

    but no dhcp


  • Yes that's to be expected.
    If a DHCP client connects he does not have an IP and thus cannot be allowed by a rule which states "only clients with such an IP are allowed".

    Have you tried to start out with a * * * * * * rule?
    Generally when i try to make a restrictive ruleset, i first allow everything and then start clamping down with tests between the steps.

    Afaik if you add a rule with
    protocol: UDP,
    source: any,
    sourceport: 68
    destination: any
    destination port: 67
    above your own rule you allow traffic to the DHCP server before the client has an IP of its own.


  • Okay… lesson learned!

    I'm by far no expert so I figured it could be bad to put a rule such as: ******

    It works with the two rules:

    protocol: UDP,
    source: any,
    sourceport: 68
    destination: any
    destination port: 67

    and

    • LAN net ****

    What is the best option? the pass all only rule or the set of two rules?

    thank you very much!