Openvpn server can't access local devices.



  • I'm now using openvpn server on Synology. I need to set port forwarding for port 433 so that I can connect to the overvpn server. Once connected, from public internet, I can access internal LAN resources and internet.

    I wish to replace it with OpenVPN server on my newly installed pfsense. I follow the procedure till I can export a ovpn file for my client PC. The instruction did not tell me to set any port forwarding for port 433; so I did not. I can connect to OpenVPN server without any extra port forwarding in pfsense. Once connected, I can access internet; but not home local LAN.
    What I need to set up more so that I can access both internet and my home local LAN?
    Thank you for any suggestion.



  • Did you add a firewall rule on OpenVPN interface to permit access? If you used the wizard, it should be set automatically.

    Also ensure that the LAN devices you want to access do not block access from other subnets. By default desktop firewalls as well as that ones of NAS block such access.

    To investigate the routing you may try a ping for VPN client to the LAN address of pfSense.



  • Thanks. I use wizard to create it. I think I've solved the problem by checking the "redirect ipv4 gateway".

    I also installed pfblockerng and it works fine. I thought when I vpn to pfsense, all the ads will be automatically blocked too; but it is not. I don't know how to make it block the ads when I vpn from the public network.

    Any suggestion? Thanks



  • Thank you all for your contribution.

    I finally solved the "overvpn not using pfblockerng filter" by simply adding pfsense IP address (192.168.2.1) in to the OpenVPN server setting-->Advanced Clients Setting-->DNS server enabled-->DNS Server 1.

    No need to regenerate/export client ovpn file.


Log in to reply