VPN Server to External VPN service, no LAN access



  • Ive got the open server working at 99% right to my needs except for 1 issue i cant work out. The setup as follows.

    pfSense 2.4.4_3

    OpenVPN server (10.10.77.0/24) on the pfsense is working correctly for LAN access and internet access if i set the openvpn gateway to default...

    But, i want the openvpn gateway set to my expressvpn server, which if i set this, i have internet access through the pfsense openvpn to the expressvpn service, so this is all good and what i need, but now the issue is, i can still access the pfsense firewall at 192.168.2.1, but i cant access any other LAN devices when the gateway is set for the expressvpn.

    So im guessing im missing some firewall rule to allow the LAN access??

    any help would be appropriated.


  • LAYER 8 Global Moderator

    @MidKnight said in VPN Server to External VPN service, no LAN access:

    i can still access the pfsense firewall at 192.168.2.1, but i cant access any other LAN devices when the gateway is set for the expressvpn.

    If your going to force traffic out a gateway, you need to allow what you want to your other local network before you force the traffic out a gateway.

    Rules are evaluated top down, first rule that trigger wins.. If you force traffic out a gateway - how would it get to your other local networks.. So put a rule above where you force it out that allows traffic to your other local network(s).



  • This post is deleted!


  • @johnpoz

    thanks mate, i worked it out and its now working 100% to my needs.


Log in to reply