HUAWEI e8732-h as WAN



  • @Rupesh first of all check your modem by plug it to your pc. There should be additional interface with 192.168.8.0/24 subnet. If so you can plug your lte modem to pfsense box and reboot it. Then login to pfsense and see all available interfaces (Interfaces -> Interface Assignments) Modem also should be available in the list.



  • @Renat it is just a simple web interface with usage details and connected client list.. however I'm still gonna do that restart of pfsense



  • @Renat does pfsense work with usb tethering as wan?



  • @Rupesh I already tested it (the same model). It works fine. But it is better to use external LTE router connected to pfsense with UTP cable.



  • @Renat I followed the procedure to install modeswitch(didn't go exactly as mentioned for 2.3 but I could install it) and creating LTE.cfg and LTE.sh( made it executable) files.and setting up in shell command. Still I'm unable to find anything listed under ppp interface.
    I have pfsense 2.4.4 does this has anything to do with me unable to get it to work ?



  • @Rupesh it is something wrong with your modem. 8372 should be available as ethernet port (not ppp). Unfortunately I haven't it right now and cannot show you.
    Pls check available network ports here:
    bc0b1a48-f733-4f18-ac7a-ccadada58e1d-image.png


  • Netgate Administrator

    What do you see in the system log when you first connect the modem?

    What do you see when you run usbmodeswitch?

    Steve



  • @Renat I will run reinstall pfsense again and share the screenshots



  • 2019-08-03_14-54-18.png 2019-08-03_14-50-12.png 2019-08-03_14-49-25.png 2019-08-03_14-47-45.png



  • usb mode switch wasant getting installed so i followed this https://monach.us/operations/usb_modeswitch_on_pfsense/




  • Netgate Administrator

    Look at the System Log in Status > System Logs > System tab.
    Connect the modem. Recheck the log, paste new entries here so we can review them.
    usb_modeswitch is in the pfSense repo you can just install it normally:

    [2.4.4-RELEASE][root@5100.stevew.lan]/root: pkg install usb_modeswitch
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    The following 1 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	usb_modeswitch: 2.5.2 [pfSense]
    
    Number of packages to be installed: 1
    
    59 KiB to be downloaded.
    
    Proceed with this action? [y/N]: y
    [1/1] Fetching usb_modeswitch-2.5.2.txz: 100%   59 KiB  60.2kB/s    00:01    
    Checking integrity... done (0 conflicting)
    [1/1] Installing usb_modeswitch-2.5.2...
    [1/1] Extracting usb_modeswitch-2.5.2: 100%
    

    Run USB Mode Switch as shown here: https://forum.netgate.com/post/99859
    Post the output from usb_modeswitch.

    Check the system log again for new entries and post them here for review.

    Steve



  • @stephenw10 2019-08-03_18-38-53 syslog.png This is the system log




  • Netgate Administrator

    Ok, so run usb_modeswitch again the custom config file as shown in that linked thread and then recheck the system log (you can just copy and paste the log text here rather than using screen shots).

    Steve



  • Aug 8 09:08:07 check_reload_status Reloading filter
    Aug 8 09:08:10 check_reload_status Linkup starting em0
    Aug 8 09:08:10 kernel em0: link state changed to UP
    Aug 8 09:08:11 php-fpm 62554 /rc.linkup: DEVD Ethernet attached event for wan
    Aug 8 09:08:11 php-fpm 62554 /rc.linkup: HOTPLUG: Configuring interface wan
    Aug 8 09:08:11 check_reload_status rc.newwanip starting em0
    Aug 8 09:08:11 php-fpm 62554 /rc.linkup: calling interface_dhcpv6_configure.
    Aug 8 09:08:11 php-fpm 62554 /rc.linkup: Accept router advertisements on interface em0
    Aug 8 09:08:11 php-fpm 62554 /rc.linkup: Starting rtsold process
    Aug 8 09:08:13 php-fpm 76178 /rc.newwanip: rc.newwanip: Info: starting on em0.
    Aug 8 09:08:13 php-fpm 76178 /rc.newwanip: rc.newwanip: on (IP address: 192.168.65.132) (interface: WAN[wan]) (real interface: em0).
    Aug 8 09:08:13 php-fpm 76178 /rc.newwanip: Gateway, none 'available' for inet6, use the first one configured. 'WAN_DHCP6'
    Aug 8 09:08:14 php-fpm 62554 /rc.linkup: Gateway, none 'available' for inet6, use the first one configured. 'WAN_DHCP6'
    Aug 8 09:08:14 check_reload_status Restarting ipsec tunnels
    Aug 8 09:09:08 php-fpm 62554 /rc.linkup: The command '/usr/local/sbin/unbound -c /var/unbound/unbound.conf' returned exit code '1', the output was '[1565255348] unbound[33019:0] error: bind: address already in use [1565255348] unbound[33019:0] fatal error: could not open ports'
    Aug 8 09:09:08 php-fpm 76178 /rc.newwanip: Resyncing OpenVPN instances for interface WAN.
    Aug 8 09:09:08 php-fpm 76178 /rc.newwanip: Creating rrd update script
    Aug 8 09:09:09 check_reload_status updating dyndns wan
    Aug 8 09:09:09 check_reload_status Reloading filter
    Aug 8 09:09:10 php-fpm 76178 /rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 192.168.65.132 -> 192.168.65.132 - Restarting packages.
    Aug 8 09:09:10 check_reload_status Starting packages
    Aug 8 09:09:11 php-fpm 62554 /rc.start_packages: Restarting/Starting all packages.
    Aug 8 09:13:55 kernel em0: link state changed to DOWN
    Aug 8 09:13:55 check_reload_status Linkup starting em0
    Aug 8 09:13:56 php-fpm 72020 /rc.linkup: DEVD Ethernet detached event for wan
    Aug 8 09:13:57 check_reload_status Reloading filter
    Aug 8 09:14:00 check_reload_status Linkup starting em0
    Aug 8 09:14:00 kernel em0: link state changed to UP
    Aug 8 09:14:01 php-fpm 72020 /rc.linkup: DEVD Ethernet attached event for wan
    Aug 8 09:14:01 php-fpm 72020 /rc.linkup: HOTPLUG: Configuring interface wan
    Aug 8 09:14:01 check_reload_status rc.newwanip starting em0
    Aug 8 09:14:01 php-fpm 72020 /rc.linkup: calling interface_dhcpv6_configure.
    Aug 8 09:14:01 php-fpm 72020 /rc.linkup: Accept router advertisements on interface em0
    Aug 8 09:14:01 php-fpm 72020 /rc.linkup: Starting rtsold process
    Aug 8 09:14:02 php-fpm 86172 /rc.newwanip: rc.newwanip: Info: starting on em0.
    Aug 8 09:14:02 php-fpm 86172 /rc.newwanip: rc.newwanip: on (IP address: 192.168.65.132) (interface: WAN[wan]) (real interface: em0).
    Aug 8 09:14:03 php-fpm 86172 /rc.newwanip: Gateway, none 'available' for inet6, use the first one configured. 'WAN_DHCP6'
    Aug 8 09:14:03 php-fpm 72020 /rc.linkup: Gateway, none 'available' for inet6, use the first one configured. 'WAN_DHCP6'
    Aug 8 09:14:03 check_reload_status Restarting ipsec tunnels
    Aug 8 09:14:05 php-fpm 72020 /rc.linkup: The command '/usr/local/sbin/unbound -c /var/unbound/unbound.conf' returned exit code '1', the output was '[1565255645] unbound[26322:0] error: bind: address already in use [1565255645] unbound[26322:0] fatal error: could not open ports'
    Aug 8 09:14:05 php-fpm 86172 /rc.newwanip: Resyncing OpenVPN instances for interface WAN.
    Aug 8 09:14:05 php-fpm 86172 /rc.newwanip: Creating rrd update script
    Aug 8 09:14:06 check_reload_status updating dyndns wan
    Aug 8 09:14:06 check_reload_status Reloading filter
    Aug 8 09:14:07 php-fpm 86172 /rc.newwanip: pfSense package system has detected an IP change or dynamic WAN reconnection - 192.168.65.132 -> 192.168.65.132 - Restarting packages.
    Aug 8 09:14:07 check_reload_status Starting packages
    Aug 8 09:14:08 php-fpm 86172 /rc.start_packages: Restarting/Starting all packages.
    Aug 8 09:22:40 sshd 13916 user admin login class [preauth]
    Aug 8 09:22:44 sshd 13916 user admin login class [preauth]
    Aug 8 09:22:45 sshd 13916 Accepted password for admin from 10.10.10.11 port 51077 ssh2




  • Netgate Administrator

    I still don't see where you have created the custom conf file and run usbconfig against that like it shows here:
    https://forum.netgate.com/post/99859

    It's not going to change mode until you do that.

    Steve






  • Netgate Administrator

    Remove that file from rc.d, reboot and run that at the command line. What is the output?

    Does the usbconfig output change when you run it?

    What is logged in the system log.

    That cfg file should not be in /usr/local/sbin. It would be better /root or somewhere else that will not get overwritten at update.

    Steve


Log in to reply