squid proxy blocking soundhound searches



  • I currently have squid proxy enabled for both http/https (without squid guard for the moment).
    All my usual stuff is working fine except I cannot do soundhound searches with squid enabled.

    If i disable squid the searches are working,
    if enabled I receive an error on the application that it could not connect.

    I can't see anything to indicate what is blocking it.

    I can i enable the soundhound search through the proxy ?



  • @gwaitsi it appears to be the SSL on the proxy that is blocking the search function. Turn that off and the search works.



  • To fix this you do this

    1. setup a WPAD (make web browser use it )
    2. Manual configure any device that cannot use a WPAD
    3. Use transparent proxy with MITM splice all to catch the rest
      https://forum.netgate.com/topic/100342/guide-to-filtering-web-content-http-and-https-with-pfsense-2-3/178


  • @aGeekhere

    • setup wpad according to your instructions
    • have confirmed it is working i.e. disabling squid, i can't browse internet in 80/443
    • google dns redirect does force safesearch

    i still get "couldn't connect to soundhound" when trying to open the app for song searching.

    If i allow 80/443 amd disable squid it works. so definitely related to squid config

    But i can't see a log, etc that can show me what is being blocked, or what i need to bypass.



  • With SquidGuard disabled and the soundhound IPs added to the bypass proxy of SquidProxy;

    Test Case 1

    • Port 443 blocked, IPs Bypass proxy, Squidproxy On - Soundhound Error
    • Port 443 blocked, IPs Bypass proxy, Squidproxy Off - Soundhound no Error

    Test Case 2

    • Port 443 unblocked, IPs Bypass proxy, Squidproxy On - Soundhound Error
    • Port 443 unblocked, IPs Bypass proxy, Squidproxy Off - Soundhound no Error

    No body has any idea? Is squid not so much used on pfsense?



  • Which device has the issue? PC, android or iPhone?


Log in to reply