Openvpn client with Aircard 815s for WAN

  • I have a system running 2.4.4 using a Netgear Aircard 815s connected via USB.

    I had to fiddle with the config and issue a usbconfig statement as an early shell command to get the interface to come up boot.

    Now that it works and I am able to pass traffic.

    I tried to configure this as a openvpn client to connect to another pfSense, and it gives me an error that it cannot start the service.

    I won't have access to the system to give the exact error message until later, but are there any known issues with openvpn over USB or with this particular card?

    I know USB is a terrible interface, but it's what I've got and I've had a hard time finding a device that will accept a sim card and give me ethernet at a reasonable price.


  • I have not tried this (USB) but.. Can you show your VPN setups? Just obfuscate any personal information such as your "server" IP and key..

    You do not have to assign your OpenVPN instance to a interface if you are doing that.

  • Sorry, but I won't have access to this system until this evening.

    I will say the config matches a couple that I have in service.

    P to P shared key

    UDP on IPv4

    Layer 3

    Interface wan

    Local port Blank

    Server Host I've tried the correct IP and hostname

    Port 1199 (I'm using 1195-1198 for other OpenVPN tunnels)

    Proxy stuff is blank

    The rest of the IP stuff I built matching my other working endpoints.

    The only thing I see different looking at one of my working sites, is that I remember setting the Gateway Creation to IPv4 only rather than both. I don't think that is the issue. The error I see is unable to contact Daemon.

    Side note, I used to use this same aircard with an SG1000 that worked pretty well. Until lightning found it about a year ago. Trying to rebuild this using a Dell.

  • Check the modem when you can for VPN passthrough. I know both my Cradlepoint and my Novatel MIFI units can screw with VPN and even log the instances. I have to allow on at least one of them. Maybe both. Ive done so a while ago so do not remember the specifics.

  • @chpalmer

    The OpenVPN passthrough is probably my issue. A web search of Aircard 815s VPN passthrough takes me to a manual page showing how to browse to the option on the Aircard.

    I'm going to try this when I get home tonight and I'll post the results.

    Thanks for your help on this one.

  • Once I logged into the Aircard I found that VPN Passthrough was already enabled.

    I disabled it and enabled the DMZ option. Now works.

    Been using it for a few days now for a mobile IP phone, and it works fairly well. Unfortunately, it is a bit cumbersome.

    I'm going to see if I can find an old laptop with a 4g card that I can run pfSense on. This will put everything in one package and will have battery on board.

Log in to reply