Active pfBlockerNG CRON JOB - high CPU



  • Hi all,
    pfsense 2.4.4-RELEASE-p2 PC running happily for years using the amazing package that is pfBlockerNG.

    Last couple of weeks I've noticed the CPU ramping up to 100% and the culprit is pfBlockerNG.
    If I reboot it's OK, then I do an update and it sticks on
    ===[ DNSBL Process ]================================================
    Missing DNSBL stats and/or Unbound DNSBL conf file - Rebuilding

    The first reboot it stuck on
    ===[ DNSBL Process ]================================================
    Missing DNSBL stats and/or Unbound DNSBL conf file - Rebuilding
    Alexa Database downloading ( approx 21M ) ... Please wait ...

    Now it just does the first bit and sits with the Active pfBlockerNG CRON JOB message in the GUI.

    I have been into the command line and killed the process:

    ps auxww | grep pfb
    root  85635 100.0  0.3  53320 37576  -  R    09:06   17:43.01 /usr/local/bin/php /usr/local/www/pfblockerng/pfblockerng.php update
    root  88059   0.0  0.0  10420  6728  -  S    09:21    0:00.00 /usr/local/sbin/lighttpd_pfb -f /var/unbound/pfb_dnsbl_lighty.conf
    root  89306   0.0  0.2  51208 35976  -  S    09:21    0:00.20 /usr/local/bin/php -f /usr/local/pkg/pfblockerng/pfblockerng.inc dnsbl
    kill 85635
    
    

    Then the CPU goes back to normal. So something is preventing the program downloading updates.

    I have updated from 2.1.4_16 which is was on to 2.1.4_17 but no difference.

    Advice welcome - should I totally uninstall it or is there some config file I can check?



  • If it was working OK before, I'd say save your setting and un/reinstall.
    But I'm using the latest dev version w/o issues.



  • Try turning off Alexa Whitelist and see if it will complete downloading the updates. That's what worked for me (also using 2.1.4_17)



  • Thanks for the answer.

    I ended up just leaving it to run the CRON job for a day rather than forcing the update.

    It cleared itself up. Sorry for the unsatisfying resolution!


Log in to reply