TLS Handshake failed only when accessing remotely



  • Hi everyone,
    I'm having an unusual problem with OpenVPN on PFSense.  I have set up the VPN server on Pfsense and the client on a PC and if I connect from the network on the WAN side of the firewall (with a public IP address block we use) I am able to connect to the VPN fine.  However when I try and connect remotely I receive an error when using UDP saying TLS Handshake failed or TCP: connect to X.X.X.X:1189 failed (with TCP), which I believe are fairly generic error messages.  The traffic does reach the firewall though as it is logged by the firewall rule.

    I've tried changing the set up (Open VPN config on the firewall, firewall rule and client setting) to TCP and I've tried with various port numbers (TCP and UDP) including 80 and 443 however with no luck.

    Anyone ever come across this before?  I would think it was some ISP issue with passsing VPN traffic but the fact the traffic is logged on the firewall says that it is getting there.



  • Doesn't matter, just got it working.  I tried using TCP port 80 and it worked (whereas TCP port 443 hasn't).  Funny old thing Open VPN but it does the job!


Log in to reply