How to figure out required details for firewall rule

  • Hi all,

    currently I have the following problem:

    I set up my pfSense and added some (most common) rules and everything is working fine so far.

    But now my son tried to start one of his favorite games on his Android mobile. Before/without pfSense it starts without problems. But now it hangs with a "No connection" message.
    So pfSense obviously seems to block something here.

    And that's my current problem: I'm trying to figure out WHAT exactly I need to enable/allow, but I cannot find any hint in the logs.
    Of course, I can see some log entries wich are blocked by "Default deny rule IPv4 (1000000103)". But none of them seem to be related to the mobile request.

    So, I tried to get some more details by capturing packages. When activating the "Allow LAN to Any" rule for testing purposes the following is returned (and the game starts/connects) without any problems:

        MYROUTER.54943 > [udp sum ok] 38697+ A? (37)
        MYROUTER.47441 > [udp sum ok] 34973+ A? (37) > MYROUTER.54943: [udp sum ok] 38697 q: A? 8/0/0 A, A, A, A, A, A, A, A (165) > MYROUTER.47441: [udp sum ok] 34973 q: A? 8/0/0 A, A, A, A, A, A, A, A (165)
        MYROUTER.50882 > [udp sum ok] 57956+ A? (43) > MYROUTER.50882: [udp sum ok] 57956 q: A? 2/0/0 CNAME, A (97)
        MYROUTER.57155 > [udp sum ok] 60654+ AAAA? (51) > MYROUTER.57155: [udp sum ok] 60654 q: AAAA? 0/1/0 ns: SOA 1 7200 900 1209600 86400 (131)
        MYROUTER.35296 > [udp sum ok] 60654+ AAAA? (51) > MYROUTER.35296: [udp sum ok] 60654 q: AAAA? 0/1/0 ns: SOA 1 7200 900 1209600 86400 (131)
        MYROUTER.56656 > [udp sum ok] 45712+ A? (51) > MYROUTER.56656: [udp sum ok] 45712 q: A? 1/0/0 A (67)

    But when deactivating the "Allow LAN to Any" rule again, the AAAA records are missing, what seems to be the cause from my point of view:

        MYROUTER.1801 > [udp sum ok] 64930+ A? (37)
        MYROUTER.37938 > [udp sum ok] 42085+ A? (37) > MYROUTER.1801: [udp sum ok] 64930 q: A? 8/0/0 A, A, A, A, A, A, A, A (165) > MYROUTER.37938: [udp sum ok] 42085 q: A? 8/0/0 A, A, A, A, A, A, A, A (165)
        MYROUTER.63627 > [udp sum ok] 51734+ A? (43) > MYROUTER.63627: [udp sum ok] 51734 q: A? 2/0/0 CNAME, A (97)   

    So, what is missing here to get the entire traffic allowed? How can I figure out which port, etc. needs to be allowed?

    Many thanks in advance!

  • LAYER 8

    the rules order is important, you should make a screenshot of what you have for the LAN interface, and tell us what are you using for the wifi.

  • @kiokoman Thanks for your reply. Yes, of course I know that the rule oder matters. But I was able to solve it myself now.
    I installed Packet Capture for Android on the phone, started the game and figured out that two port are required. After these port have been allowed on pfSense the game started as expected. :-)

Log in to reply