Broke pfSense and OpenVPN again.

  • I was making changes to my firewall and vpn to be able to access my switch. I am getting these errors,
    "Thu Oct 10 01:42:29 2019 TLS Error: Received control packet from unexpected IP addr: [AF_INET]...:1194
    Thu Oct 10 01:42:31 2019 TLS Error: local/remote TLS keys are out of sync: [AF_INET] [0]".
    I have done more research into these issues and found different results for the TLS keys, but nothing on the control packet, I found the one that was for the unroutable but not the received.
    I have tried what I found people have said worked for them with the "reneg-sec 0" on the client and "reneg-sec 36000" on the server, to try the fix the TLS error and didn't work.

  • Forgot to post an update when I fixed this, for people who might have this issue later. Check the client output settings, make sure it is set on the version 2.4+ and it points to either your domain/wan IP address. I will admit that me being a newbie I never looked at that and just went for the client output. I still get a keys out of sync error but that is because the internet drops a packet or 2 on connection, what do you expect from free wifi though.

Log in to reply