Squid Redirector



  • Hello

    Install 2.3.5
    squid
    squidguard

    Under Squid :-
    General Settings > Advanced Feature > Integrations

    Default Vaule is :-
    url_rewrite_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf;url_rewrite_bypass off;url_rewrite_children 16 startup=8 idle=4 concurrency=0

    Changed Some Values :- url_rewrite_children 32 startup=8 idle=20 concurrency=0

    Now everything works fines , restarted squid service and everything is fine.

    But when i do any configuration change in squid-guard package and click on "Save" then "Apply"

    Now my custom values changes back to default :-
    url_rewrite_children 16 startup=8 idle=4 concurrency=0

    Some time back i worked around by changing values directly in /usr/local/pkg/squidguard_configurator.inc

    Any idea how to fix this ?



  • I'm pretty sure I've changed these in the past and they stick.

    Is there some reason why you're running such an old version? 2.3.5 is two years old now.



  • actually I´m no able to update thought web gui always give an error and I have never done it in any other way so... Im no expert and since is in production i rather not measing wth it if im not sure of what Im doing



  • You might be running on x86 hardware which I think is capped at 2.3.5.

    Are you saying that the setting is saved when you make the change in squid and save, but it reverts back to the old settings when you make a change in squidguard?



  • @KOM yes once I aply changes on Squidguard I have change again on Squid



  • OK, now I understand. I can also reproduce that problem.

    There is an update to squidguard but it does not fix the issue.



  • Just an Update

    I did a fresh install of 2.4.4 version, same problem

    any suggestions?



  • Report the bug on redmine.


Log in to reply