redirection de port et redirection vers routeur



  • Bonjour
    Je suis en train de remplacer un routeur/FW TPLINK (Archer C5) par une solution PFSENSE.
    J'ai installé la dernière version de pfsense (2.4.4-RELEASE-p3) sur un boitier Quotom.
    J'arrive à accéder à internet et je réussi à le configurer comme point d'accès Wifi. => YES !
    Mais j'ai un NAS et deux boitiers domotique que je veux pouvoir piloter depuis le Net. TOus cela fonctionnait très bien avec la Archer.
    Mon Nas est configuré pour publier l'adresse IP Public de ma box et je peux donc y accéder MONNAS.myqnapcloud.com.
    Je veux pouvoir rediriger le port 8080 vers l'IP de mon NAS et le Port 1880 vers mon serveur web domotique N°1
    Déjà je n'arrive pas à configurer pfsense pour faire cela.
    J'ai suivi plusieurs technote (et surtout celle la et aussi Celle là et la rien à faire. J'ai ajouté des règles dans le FW. J'ai même rebooter le FW pour être sur. Je suis sec.

    et dans un deuxième temps je voudrais pour faire la même chose mais vers mon deuxième serveur web qui est derrière un routeur Netgear et également pouvoir accéder aux postes derrière ce routeur et que les postes puissent accéder au Net. Je voudrais router le réseau 192.168.10.0/24 depuis le 192.168.20.0 et je n'y suis pas arrivé.

    Je sais pour le deuxième routeur certains vont se demander pourquoi mais il y a des raisons qui seraient longue à expliquer.

    Donc question :
    Pour de la redirection de port est ce que les tuto que j'ai suivi suffissent?
    Faut t'il ajouter des règles dans le FW ?
    Le NAT Transfert de port suffit ?
    Qu'est ce que je n'ai pas compris dans pfsense.

    Je suis preneur de technote.

    Je suis dessus depuis une bonne journée ( avec le TPLINK j'avais mis 1 h).

    Merci a ceux qui me répondront

    Dessin de mon archi

    archi.png



  • Salut salut

    Bon première chose pourquoi deux réseaux derrière le lan du pf ?
    Quelles sont vos recherches et solutions que vous avez testé ?

    Deuxième chose
    Réaliser une configuration en 10 min ou 1h sur un produit ne signifie pas que vous maitrisez les concepts et les technologies qui en découle.

    Troisième chose
    Au vue de le présentation de votre problématique manque cruellement d'information, vous vous invite fortement a reprendre cette dernière et poussez vos recherches qui me paraissent des plus légères.



  • @Tatave Merci



  • Contexte : perso, niveau pas débutant,
    Besoin : qu'est ce qui faut faire (en français) ou qu'est ce qu'on veut faire : voir premier post

    Schéma : voir premier post

    WAN (modem/routeur/box) : nombre 1 , type BOXSFR, Bridge, nombre d'ip publique 1 , multiwan : Non

    LAN : nombre : 1 , vlan 1 , autres réseaux accédés via routeurs 1, adressage 192.168.20.0/24, dhcp fourni Oui, dns local 1Oui, …

    DMZ : Aucune

    **WIFI ** : adressage 192.168.20.0/24 , dhcp fourni Oui, dns local Oui, usage Interne

    Autres interfaces : toutes les interfaces 4 + wifi regroupées dans le même Bridge
    Image 2.png
    Image 5.png

    **Règles Firewall **: par onglet, règles principales, …
    Image 3.png
    Image 4.png

    Packages ajoutés : Aucun

    Autres fonctions assignées au pfSense : Aucun

    Question : Problème précis rencontré et questions posées, …
    :
    Voir premier Poste

    Pistes imaginées : Aucune je ne sais plus ou chercher
    Dans les log je ne vois rien.
    Quand je créer la règle de NAT la règle de FW se créer bien toute seul.
    Je vais mettre un PC entre ma box et pfsense pour voir si cela viens de la box. Sans y croire car il n'y a aucune config dans la box et que cela fonctionnait avec le TPLINK.
    Autre piste : OPNsense, remettre mon ancien firewall.

    Recherches : pour une piste, quelles recherches avec quels résultats
    Voir premier poste
    J'ai également comparée avec un autre pfsense (celui du boulot mais je n'ai pas fait la config) et je ne vois pas de différence ( dans la partie NAT et règles ).
    Je n'ai pas l'impression qu'il faille configurer ailleurs pour le transfert de port.

    Logs et tests : complément de "Recherches" : quels sont les résultats des tests effectués (section qui ne peut être vide !)
    Test essai d’accéder à mon NAS depuis l'extérieur avec un téléphone mobile.

    J'espère avoir ajouté suffisamment de détail pour avoir de l'aide.

    Merci d'avance



  • J'avance :
    Deux problèmes :
    1- Par défaut pfsense bloques les réseaux

    • 10.0.0.0/8
    • 172.16.0.0/12
    • 192.168.0.0/16

    Voir arcticle de NetGate : ICI

    Ce doit être surement utile mais bon comme beaucoup de box sont dans ces adresses là il est dommage que ce soit actif de base. ou j'ai pas compris l'utilité du truc !

    2- Problème de config de Box
    Après cette modification, je recevais bien mes trames depuis le réseau entre Pfsens et ma box (Merci les logs) mais pas depuis internet et là c'est de ma faute (et un peu aussi de la box SFR qui a plantée et que j'ai reconfiguré à l'arrache)

    -> l'adresse de la DMZ dans la box n'était pas celle de pfsense et donc les demandes issues de l’extérieur n'arrivaient pas.

    Pas contre je comprends pourquoi le flux internet marchait !

    En résumé le port forwarding marche très bien si :

    • on créer les règles dans FireWall -> NAT -> Filter rule association = add associaed rule.
      Comme ça la règle dans le FW est automatiquement créer et lié au port forwarding.
      Image 7.png
    • Si dans le menu Interface -> WAN : on désactive 'Block private networks and loopback addresses' et 'Block bogon networks'
      ATTENTION CA MODIFIE LA CONFIG DHCP ! du WAN
      Image 6.png

    Si cela peux aider quelqu'un !


Log in to reply