OpenVPN Server in tap mode - Bridge DHCP unselectable



  • Version 2.4.4-RELEASE-p3 (amd64)

    Reference point;
    https://docs.netgate.com/pfsense/en/latest/book/openvpn/bridged-openvpn-connections.html

    Server config screenshot:
    Screen Shot 2019-10-28 at 9.57.06 AM.png

    When creating, I change tun to tap. Note that the Bridge DHCP option does not appear in the Tunnel Settings:
    Screen Shot 2019-10-28 at 9.58.37 AM.png

    Hit Save, then click the pencil to edit again.
    Bridge DHCP shows up:
    Screen Shot 2019-10-28 at 10.01.48 AM.png
    However mouse cursor shows circle with line through it & does not let me enable the box.

    Assigned the ovpns1 as an Interface, and enabled the interface;
    Screen Shot 2019-10-28 at 10.14.22 AM.png

    Re-edited the OpenVPN Server config, and clicked Save to reinitialize the VPN.
    Re-edited and still could not select Bridge DHCP.

    Created Bridge:
    Screen Shot 2019-10-28 at 10.18.45 AM.png
    Although not visible, the other member interface is VLAN64.

    Re-edited the OpenVPN Server config and still could not select Bridge DHCP.

    Assigned the Bridge as an Interface;
    Screen Shot 2019-10-28 at 10.30.01 AM.png

    Re-edited the OpenVPN Server config and still could not select Bridge DHCP (and Bridge Interface is locked to none).
    Rebooting the server does not fix this.

    Enabling DHCP server on VLAN64 or on L2Bridge does not fix the inability to enable Bridge DHCP on the OpenVPN server.

    Is there anything I've missed to enable it?

    PS - need tap, not tun.


Log in to reply