Installing to Microdrive using VirtualBox



  • I installed pfsense 1.2 to a microdrive before and now I want to update to 1.2.3 so i'm installing the same way again. This time, I get FAILED with a return code of 38 when executing /sbin/newfs /dev/da0s1a

    The log file says:

    160, 376512, 752864, 1129216, 1505568, 1881920
    cg 0: bad magic number
    ->>> Exit status: 38

    Does anyone know what is wrong?



  • Same problem here.

    According to some posts before , it could be a problem with the card reader used (I use some cheap sliver line card reader).
    I am not 100% sure though whether this is a controller problem per se or maybe this is an issue with virtualbox and livecd install would work.

    Ok update!
    As it turns out 1.2.2 works just fine.
    So I suppose its a bug.
    Maybe new freebsd used with it doesn't like some card readers?

    Ok another update.
    Even though it progresses past the newfs , I still can't install.
    The progress bar appears which counts to 3 or 4 percent and then I get a kernel panic.
    After the machine is rebooted either the drive is not recognized anymore and I need to unplug , replug it in order to be recognized or I get the same error again (exit code 38).
    I will attempt using a burn the iso and see if that one works better.



  • Hello,

    The problem is in most probably in your USB CF reader. I had this problem driving me crazy, went to another platform and installed on the ALIX with CD-Rom, no problem with the same Microdrive.

    I hope it helps.



  • Well thats impossible.
    The ALIX that I have doesn't support cdrom.
    Ok maybe I could somehow hook up a laptop cdrom to its 44pin ide interface.
    According to the manual cdrom booting is not supported though.
    Maybe a different card reader?
    Also why it does start in 1.22 but crashes?



  • I have used the same card reader and the same virtualbox host to install 1.2 a long time ago. It worked then so I thought it should work now.



  • Yeah well its the tutorial for the 1.2
    I guess something changed in FreeBSD since then.
    The question is whether we can upgrade from 1.2 to 1.2.3.
    Tomorrow a friend of mine is going to be bring a laptop over with pcmcia slot.
    I have pcmcia to cf adapter so I will try that.
    Another option is of course to wait until somebody uploads us an image of full install on microdrive.


Log in to reply