Integration between captive portal and squid. Usernames are not showing in access.log file



  • Hi everyone. I am preparing a pfsense server to manage the wifi networks at my job. It already working using squid for transparent proxy/SSL filtering + squidguard and authentication through captive portal on three diferent networks (a diferent authentication method on each one). The only thing isn't working is the captive portal usernames are not showing in the access.log file, just a "-" on place. Thus, the lightsquid also not showing the users in its reports. I appreciate any help.
    Some possibly useful informations about my environment:

    • Pfsense 2.4.4-RELEASE-p3 (amd64)
    • Squid 3.5.27_3
    • SquidGuard 1.16.18_2
    • Lightsquid 3.0.6_6

    Squid config screenshots attached.

    Squidconf1.png
    Squidconf2.png
    Squidconf3.png
    Squidconf4.png

    Firewall allowed ports on local interfaces: 53, 80, 443;



  • hi. have you found the solution to this problem. pfsense was already setup when i was hired to this small business. at first the i was able to view usernames in lightsquid but after an update of pfsense and the packages. lightsquid displays IP address instead of the usernames from captive portal. hope you got this solved already.



  • Hi Alpax8,
    I've probably the same problem as yours. I made the upgrade of the packages (Squid, SquidGuard, Lightsquid) recently (the last week).
    My environment version :
    Squid : 4.10
    Squidguard : squidguard-1.4_15

    Are you in the same version ?

    I tried into a new environment in order to compare and it's exactly the same problem.

    I'll try to rollback the Squid version of my test environment and give you more informations it is working successfully.



  • Squid : 0.4.44_30
    SquidGuard: 1.16.18_7
    LightSquid: 3.0.6_6

    I tried going back but didn't fix the problem. I also tried edit the lightsquid.cfg and all but without success. hope you got yours fix.





  • I have the same problem. Someone found the solution ?



  • @nico1234 Should be fixed in https://redmine.pfsense.org/issues/10749
    Can you retest it with the latest Squid pkg?



  • resolved:
    Screenshot from 2020-10-24 13-04-48.png



  • @viktor_g im glad its fixed. but i cannot follow through on how to do it. would you please give me more steps and guide on how to do it. thanks.



  • Thank you for the answer.
    Lightsquid log with the names.
    Now squid crash after a few minutes:
    Date-Time Message
    27.10.2020 15:56:21 assertion failed: Write.cc:38: "fd_table [conn-> fd] .flags.open";
    27.10.2020 15:56:21 helperDispatch: Helper check_cp # Hlpr8 has crashed


Log in to reply