OpenVPN + PiHole = Unknown Host



  • Hello Forum!

    I was just getting started with pfSense, and my main goal for now is to reproduce the services i used on my ASUS router, and an OpenVPN connection to my home network is such a thing. I followed the steps in this absolutely perfect video about making OpenVPN setup. But unfortunately there is a little problem with my setup.

    First i made a test conection with test CA, test Server Certificate, test User and test User Certificate. I have a ddns address on the firewall which gets my correct WAN IP address (i have dynamic address from my ISP). I followed the steps and finally i had an OpenVPN connection with my home network, worked everything flawlessly from outside the network. Then i thought i will make 2 more OpenVPN server with 1 TCP and 1 UDP protocol. Followed the same video and the same steps, but at the end i couldn't use the internet. I could ping my pfsense router (192.168.1.1), and 8.8.8.8 or any other IP number, but couldn't ping for example google.com. Error: Unknown Host. I've set up the DNS Default Domain as localhost (this is my domain in pfsense), and for DNS Server 1 i've set up the pfSense router address (192.168.1.1).

    Some questions about making OpenVPN servers:

    1. For the first time when i just tried to make the test OpenVPN connection, when i only set up 1 DNS Server in the wizard, which is the pfSense router LAN address (192.168.1.1), i can connect to my home network, but i have no internet connection. This is the way it should work? I thought if i set my pfsense as the DNS Server i can connect not only to my home network, but the interner also.

    2. For the test OpenVPN because if i set the pfsense router as DNS server for the OpenVPN doesn't work for me to go out to the internet, i've set up my PiHole LAN address (192.168.1.2) as DNS Server 2. Now i can go out to the internet, i can ping google.com. But when i started to make the 2 more OVPN servers, it's not enough, if i set up only the pfsense router and the pihole as DNS Servers, i'm not able to ping goole.com again. I have to add DNS server 3 with some kind of public DNS server and i can ping google.com again. But the test server is still able to ping google.com without the need of a 3. DNS server. Does anyone have a clue where should i start to investigate the problem? Or did someone meet with this situation?

    I've used all the 3 times the OVPN client export, where the host name resolution was always my ddns address.

    For the PiHole setup i used this article, and in the pfsense the DNS Servers are the localhost (127.0.0.1), and the PiHole (192.168.1.2) only.

    Thank you guys any help you can provide to understand the OpenVPN setup!


Log in to reply