Split tunneling doens't work for Linux clients.

  • Hi guys,

    I'll be appreciated for your help with the following issue. I have OpenVPN server on my pfSense FW which is configured with "net30" topology and disabled option:
    Redirect IPv4 Gateway: Force all client-generated IPv4 traffic through the tunnel. I also use "Client Export" option to generate .ovpn config files for the clients.

    When I use "tunnelblick" VPN client on my Mac OS X, I see in "netstat -nr" output that only specific routes are pointed towards the tunnel. But on linux PCs after connecting to VPN I see:

    # ip route show
    default via <VPN_GW> dev tun0 proto static metric 50
    default via <Default_GW> dev eno1 proto dhcp metric 100

    so it installs default route with lower metric via the tunnel GW, and the native Default_GW that was before VPN setup is getting less prioritised route.
    Please help me to understand how to fix it, making a split-tunneling work for any client OS.

    Thank you.

  • The problem was caused by Network Manager which was handling the opvn config. To disable sending all traffic through the VPN do this
    Click NetworkManager applet icon > VPN Connections > Configure VPN... > select VPN network > Edit > IPv4 Settings > Routes... > Check ‘Use this connection only for resources on its network’