El portal cautivo no funciona para los dispositivos ios



  • Hola, abro aquí una consulta, a ver si alguien me puede ayudar. El problema ya viene de antes, he cambiado la configuración del servidor pfsense, pero todo sigue igual.
    El pfsense se conecta a internet por la wan, y dentro de lan, tengo tres vlans, una de gestión de switchs, una para las aps wifi. Tanto los pc como los dispositivos android, se les abre la ventana popup del portal cauito, pero en dispositivos IOS, no se abre nada, hay que abrir safari y pedir una navegación web http. Adjunto alguna capturas.

    Una duda, ¿el dominio del server tiene que ser el mismo dominio que el del portal cautivo? estoy utilizando ACME para firmar un certificado para el portal (wifipalau.duckdns.org), pero el server tiene otro diferente (local.lan)
    Hilo anterior: https://forum.netgate.com/topic/138790/the-captive-portal-does-not-redirect-to-the-login-page-on-ios-devices/11

    2019-11-20-081416_1440x900_scrot.png 2019-11-20-081411_1440x900_scrot.png 2019-11-20-080705_1440x900_scrot.png 2019-11-20-080631_1440x900_scrot.png 2019-11-20-080519_1440x900_scrot.png 2019-11-20-080433_1440x900_scrot.png 2019-11-20-075756_1440x900_scrot.png 2019-11-20-075709_1440x900_scrot.png



  • Bueno, lo he SOLUCIONADO !!!

    Después de probar todas las combinaciones posibles, al final, he encontrado el error. Era un fallo mío, al customizar el portal cautivo, no escribí bien el código o no se que hice. Poniendo el diseño por defecto que trae pfsense, los dispositivos ios abren la ventana de login al conectarse al wifi sin ningún problema. Gracias a todos por ala ayuda y la paciencia.


Log in to reply