Updating from snapshot 1116 to 1129 completely crashed my system.



  • I tried updating to the latest snapshot from a 12 day uptime on the 1116 snapshot this morning. All worked fine until the reboot. The system booted with the error :

    Booting from harddisk... Invalid format.
    Ending with BTX halted.

    Only thing I could do was restore a backup from 2.4 .. any idea what went wrong?
    A bit hesitant to update again.


  • LAYER 8

    probably i/o disk error / corrupted filesystem.
    do a backup and try again there is no other way to know for sure



  • FWIW, I just upgraded to 1129 w/o issue.



  • Use ZFS install, check your RAM with memtest, check your SSD/HDD.
    I've had some update issues month ago, when tried to switching the branch to the stable and back to the development and then updating from console. It happened once ending with a similar situation, but I've seen that it's already reported on redmine, only there ended in PHP errors on boot, mine ended with RAW filesystem on next boot after PHP errors on previous boot. So it can be both software and hardware, but it’s definitely not related to the current snapshot build number.



  • @w0w Thanks. It's running as a proxmox instance so I reverted back to an earlier snapshot. Memory / disk are OK. Might have been a glitch in the matrix.


Log in to reply