FTP issue specific to Pfsense

  • Hi Need some help,

    SG3100 runing latest build
    FTP server is running externally (with 3rd party software provider)
    FTP client used is windows CMD FTP Running on windows server 2012 r2

    Have a client who needs to connect out to an a FTP server, since swapping from watchguard to pfsense. Its stopped working. They have some 3rd party software that relies on it. Its going to be difficult for me to get them to do any development.

    I tried the same commands from other none pfsense firewalls and it works fine (sonicwall, juniper, draytek). I tried from multiple PFsense firewalls and its blocked. All rules say LAN - WAN allow all, so i dont know why its not working.

    I tried 1:1 NAT, with a spare public IP. Same issue.

    I tried the troubleshooting steps below, but same problem occurs.

    $200 for the fix, can give remote access to the firewall or FTP details, as the issue appears to be accross all PFsense hardware on default config.

    pfsense error.png

    The below is what is supposed to happen. This is from a none pfsense firewall with default settings.


  • OK, managed to fix this by installing FTP Proxy Plugin and selecting below.
    It mentions some firewall rules being created, but i dont see anything.

    ftp fix.png

Log in to reply