Ping ok ma non riesco a navigare



  • Ciao a tutti,
    Ho appena installato Pfsense pfSense-CE-2.4.4 su un vecchio PC.
    L'installazione è andata apparentemente liscia e riesco ad accedere alla GUI.

    Come WAN ho collegato un adapter usb-Rj45 (amazon basic) che prende direttamente l'indirizzo WAN dal mio router che a sua volta è collegato a un modem router Vodafone. Per il momento ho preferito fare cosi, prima di collegare Pfsense direttamente al router principale. Giusto per fare delle prove in sicurezza e senza al momento fare cambiamenti.

    La porta Ethernet del PC di cui sopra fa da porta LAN (ip rete interna 192.168.5.1), ho collegato ad essa un netbook giusto per gestire il firewall dalla GUI e navigare. Il problema è che il netbook non riesce ad accedere ad internet (icona rete con segno giallo). Dallo strumento ping di pfsense in Diagnostics riesco a pingare Google.com. Non ho capito quale sia il problema.
    Potete aiutarmi?
    Grazie



  • Sono riuscito a risolvere il problema abilitando il DNS Forwarder al posto del DNS resolver.
    Adesso il netbook naviga in internet regolarmente.
    Non so se è la soluzione idonea soprattutto per la sicurezza.
    Qualcuno gentilmente può spiegarmi perché adesso funziona e prima con DNS resolver impostato non navigavo?
    Grazie


  • LAYER 8

    dns resolver invia le richieste ai "root name server"
    dns forwarder invia le richieste ai dns server che hai specificato o che ha preso in automatico pfsense dalla wan
    non ci sono grosse differenze da questo punto di vista..
    il perchè non abbia funzionato resolver è difficile a dirsi probabilmente tutte quelle nat che hai o qualche firewall integrato nei router che hai impedivano il funzionamento o era semplicemente configurato male



  • @kiokoman said in Ping ok ma non riesco a navigare:

    dns resolver invia le richieste ai "root name server"
    dns forwarder invia le richieste ai dns server che hai specificato o che ha preso in automatico pfsense dalla wan
    non ci sono grosse differenze da questo punto di vista..
    il perchè non abbia funzionato resolver è difficile a dirsi probabilmente tutte quelle nat che hai o qualche firewall integrato nei router che hai impedivano il funzionamento o era semplicemente configurato male

    Però avevo provato anche a inserire manualmetne i DNS nelle impostazioni proprietà IPV4 della scheda di rete del netbook, ma comunque non andava. Non capisco il perché
    Grazie


  • LAYER 8

    per capire cosa succede dovresti analizzare il traffico con wireshark / tcpdump tenendo presente che il servizio dns usa la porta udp/tcp 53. ma con tutti quei router in mezzo diventa difficile, la vodafone station ha un firewall integrato oltre ad essermi scontrato più volte in problematiche di funzionamento che si risolvevano solo spegnendo e riaccendendo il modem. togli il router, metti pfsense in DMZ sulla vodafone station e configuralo direttamente li.



  • @kiokoman said in Ping ok ma non riesco a navigare:

    per capire cosa succede dovresti analizzare il traffico con wireshark / tcpdump tenendo presente che il servizio dns usa la porta udp/tcp 53. ma con tutti quei router in mezzo diventa difficile, la vodafone station ha un firewall integrato oltre ad essermi scontrato più volte in problematiche di funzionamento che si risolvevano solo spegnendo e riaccendendo il modem. togli il router, metti pfsense in DMZ sulla vodafone station e configuralo direttamente li.

    Si in effetti è un po' un casino come è collegato il firewall alla rete esterna.
    Vorrei approfondire la faccenda della DMZ comunque, se non ti dispiace.
    Conviene tenere Pfsense in una DMZ, quindi assegnando una indirizzo IP statico, ma comunque privato alla porta WAN del firewall, oppure disabilitare completamente il NAT sul modem vodafone (sempre che sia possibile sul router-modem della Vodafone; non ho mai affrontato questa questione) e fare assegnare l'Ip pubblico alla WAN direttamente in pfsense?
    Grazie


  • LAYER 8

    non credo sia possibile mettere la vodafone station in bridge, altri qui sul forum l'hanno messo in DMZ con ip statico locale ovviamente. teoricamente potresti montare un modem libero e con i parametri forniti sul sito vodafone puoi configurarlo in bridge e far assegnare l'ip direttamente a pfsense



  • @kiokoman said in Ping ok ma non riesco a navigare:

    non credo sia possibile mettere la vodafone station in bridge, altri qui sul forum l'hanno messo in DMZ con ip statico locale ovviamente. teoricamente potresti montare un modem libero e con i parametri forniti sul sito vodafone puoi configurarlo in bridge e far assegnare l'ip direttamente a pfsense

    Capisco,
    Quindi il modem/router di Vodafone non permette di farlo, ma teoricamente possibie con altri modem liberi o magari ci sono quelli forniti da altri ISP che lo consentono.
    Grazie per la risposta


Log in to reply