Tcsetpgrp failed, errno=25 and some pppoe issues (mostly solved).



  • Ok first of this strange issue (I understand it was happening in older releases to).
    In serial console I see this when I try either to press enter at the menu or choose shell (probably other choices too didn't check).
    Also regarding PPPOE :
    If I unplug the wan cable , the only way to reconnect to the internet is by rebooting the pfsense box.

    Ok just to make sure I am running 1.2.3RC1 (the official RC1 release) on alix2c2 , full version on a microdrive.

    Ok an update of the first issue (I was on idiot).
    Turns out I forgot to enable serial console in the gui.
    After I enabled it I don't have anymore messages like that.
    The interesting question however , is how come I was able to access serial console if it was disabled in the settings?
    The problem with pppoe is was because I tried upgrading 1.3 with 1.2.3 for which I apologize.
    After I wiped everything out , installed 1.2 image and then upgrade to 1.2.3RC1 pppoe seems to be working OK.


Log in to reply