DNS e router Wind Home&Life HUB (sercomm wd300)



  • Salve a tutti. Mi scuso subito per il wall of text, ma purtroppo ci sono parecchie cose da dire, spero di essere riuscito a tenere tutto abbastanza ordinato.
    Sono qui per chiedere un consiglio per riuscire a far funzionare pfsense in abbinata a questo router. Purtroppo qualche giorno fa sono stato costretto a cambiare operatore per la connessione di casa e mi hanno rifilato questo router e purtroppo la cosa mi sta causando non pochi problemi con pfsense.

    L'obiettivo in teoria è tutto sommato semplice, vorrei semplicemente tornare ad usare pfsense con dns resolver come lo usavo su rete tim.

    Vi elenco brevemente le prove già fatte ed i problemi riscontrati.

    • configurazione modem stock eccetto aver assegnato alla macchina pfsense un ip statico ed aver messo quell'ip nella dmz. Configurazione pfsense precedente (perfettamente funzionante con tim) con dns resolver attivo:
      • i pc collegati direttamente al router accedono ad internet ed usano i dns wind
      • i pc collegati a pfsense accedono ad internet (pingano verso l'esterno) ma non ricevono risposte dal dns
    • modem come al punto precedente. pfsense con dns forwarder attivo e resolver disattivato, dns impostato su 1.1.1.1
      • pc collegati al modem continuano a funzionare come prima
      • pc collegati a pfsense accedono ad internet ma dnsleaktest rivela che in realtà stanno usando i dns wind
    • dns configurati sul modem nella sezione network>rete locale LAN>valori dns con dns statico e server dns 1.1.1.1. pfsense come sopra
      • tutti i pc ignorano la configurazione e continuano ad usare i dns wind
    • dns configurati nella sezione network>broadband>vdsl>server dns del modem. pfsense come sopra
      • telefoni smettono di funzionare (ma questo non è un problema), pc collegati al modem funzionano correttamente e sembrano usare i dns corretti
      • pc collegarti a pfsense funzionano e sembrano usare i dns impostati da pfsense, ma non tutte le query dns ricevono risposta.
    • modem wind sostituito con il vecchio modem tim (dns non impostabili dal modem ma con tim accettava senza problemi i dns impostati sui client ed il resolver di pfsense), pfsense con resolver attivo
      • i pc collegati a pfsense navigano senza alcun problema, però dnsleaktest rivela che in realtà usano i dns di wind.

    credo siano tutte le prove fatte.
    Idee?


  • LAYER 8

    mi risulta che wind dia lo zyxel 8825 o il dlink dv-5592, il sercomm non ho avuto ancora il piacere di metterci le mani ne vederlo nonostante lavori in un centro wind .....
    io li ho entrambi e lo zyxel aggancia 10 mega in più rispetto al dlink ... puo' essere che mi sia capitato un modem poco sensibile .. comunque
    se non ti interessa la parte telefonica fai come me, mettilo in bridge e lascia gestire la connessione a pfsense. sono bloccati i modem ma se cerchi in rete trovi come sbloccarli abbastanza facilmente .. almeno per lo zyxel e il dlink, probabilmente c'e' qualcosa anche per il sercomm
    l'alternativa è di comprarti un modem libero .. tieni presente che quello che danno gli operatori sono abbastanza delle ciofeche



  • @kiokoman intanto grazie mille. purtroppo da qualche mese danno anche il sercomm, da quel che ho letto è praticamente un clone dello zyxel con la stessa scocca esterna e qualche bug in più. Il Bridge non l'ho provato ma da quel che ho letto su altri forum è una delle parti buggate di questo modem, in più la macchina pfsense la sto ancora testando, al momento tutti i miei dispositivi passano da li ma fin che non sono del tutto soddisfatto della configurazione il resto della famiglia si connette direttamente al modem così si evitano un po' di problemi, quindi direi che almeno per il momento il bridge non è fattibile.

    L'idea del modem libero mi attira e mi stavo già guardano attorno ma devo ancora decidermi. Comunque tutte le limitazioni sono solo sul modem o c'è anche qualcosa a livello di rete? I problemi che sto avendo mi fanno pensare ad un proxy dns ma mi sembra strano che sia tutto gestito solo sul modem. Tu per caso hai qualche informazioni in più a riguardo?


  • LAYER 8

    non credo che wind faccia e che neanche possa fare redirect delle query dns, più probabile che sia un problema di modem. per contro posso dirti che io in bridge su rete wind non ho nessun problema in azienda.
    che sappia io la porta 53 è bloccata da wind solo in ingresso e non in uscita.



  • Beh, questa è un ottima notizia, nel peggiore dei casi se proprio non trovo altre soluzioni posso sperare in un aggiornamento del firmware, da quel lato sembrano essersi impegnati un minimo negli ultimi mesi. Grazie mille


Log in to reply