Transfer my config to new device



  • I had a SG-2440. I now have a SG-5100 and am attempting to replicate some of my old config on the 5100.
    The Restore function has a setting for openVPN but that restore doesn't restore the certificates. So I tried export from 2440 & import to 5100 but that isn't working for me. The server does not start.

    Next I tried running through the wizard and importing the certs/keys at the appropriate place. That fails with something like the port is in use. The port I'm using is 443-udp (because I figure that port is generally available on locked down systems).

    How can I resolve this roadblock?



  • Updating my own post, regarding the openVPN server not starting. I forgot about the log. So the log says "Insufficient key material or header text not found in file '/var/etc/openvpn/server1.tls-auth' (0/128/256 bytes found/min/max)".

    The TLS key I am using is imported from my setup in SG-2440. I checked the above location and confirm they are the same, although the filename on the 2440 is server2.tls-auth. The openVPN server will not start.

    Any idea about what I'm missing as indicated by the error in the log?

    My last resort is the create new certs/keys but I would rather find a fix for this problem I have.



  • Finally, I found it. The server1.tls-auth file needed crlf on each line. When I copied that file it produced a single string of characters that was not formatted properly. After adding a crlf on each line and re-saving the openVPN server, returning to services found the openVPN server running.


Log in to reply