ACME 0.6.4 Godaddy DNS showing invalid domain



  • I have been using the ACME plugin with the method "DNS-Godaddy" on one of my firewalls for a while now without issue. I recently built a new firewall (Version 2.4.4-RELEASE-p3) and I am running the acme package version 0.6.4 on it. I have been getting an error when trying to get the dns auth to work from godaddy. I am able to get the same domain to work on my other firewall running pfsense 2.4.4-RELEASE-p2 and acme package 0.5.5_1. This appears to be a bug in the 0.6.4 package. I have tried both staging v2 and production v2.

    Here is a snip of my logs:

    [Mon Dec 16 13:51:10 CST 2019] First detect the root zone
    [Mon Dec 16 13:51:10 CST 2019] domains/net
    [Mon Dec 16 13:51:10 CST 2019] GET
    [Mon Dec 16 13:51:10 CST 2019] url='https://api.godaddy.com/v1/domains/net'
    [Mon Dec 16 13:51:10 CST 2019] timeout=
    [Mon Dec 16 13:51:10 CST 2019] Http already initialized.
    [Mon Dec 16 13:51:10 CST 2019] _CURL='curl -L --silent --dump-header /tmp/acme/my_domain.org_SAN_Cert//http.header -g '
    [Mon Dec 16 13:51:10 CST 2019] ret='0'
    [Mon Dec 16 13:51:10 CST 2019] response='{"code":"NOT_FOUND","message":"Domain net not found for shopper"}'
    [Mon Dec 16 13:51:10 CST 2019] net not found
    [Mon Dec 16 13:51:10 CST 2019] invalid domain
    [Mon Dec 16 13:51:10 CST 2019] Error add txt for domain:my_other_domain.net
    [Mon Dec 16 13:51:10 CST 2019] _on_issue_err

    I have also removed and reinstalled the acme package. I created a new API key and tried that as well. Any help is appreciated.


Log in to reply