[ipsec] keep alive pfsense



  • Bonjour à tous , j'ai actuelle en test une connection vpn ipsec (3des ESP) entre un netopia et pfsense.
    Tout fonctionne à merveille , la seule problèmatique que je recontre est lorsque je simule une coupure sur le netopia , je suis obligé de relancer le service ipsec sur pfsense pour que la connection vpn s'établie à nouveau.

    Par contre si je débranche le pfsense et que je le rebranche , pas de problème la connection se rétablie .

    j'ai mis dans la section keep alive

    Keep alive
    Automatically ping host
    10.1.1.1                     -> qui correspond à l'adresse ip privé de mon netopia.
    j'ai aussi fait le test de ping quand le connection est établie à partir de la pate lan sur 10.1.1.1 est j'ai bien une réponse.

    J'ai aussi tenté de baisser le Lifetime a 3600 au lieu de 28800 , mais pas d'amélioration ….

    Si vous avez une idée sur le problème n'hesitez pas à m'en faire part

    Merci d'avance



  • Tiens ! Cela met le doigt sur un problème que j'ai aussi sur ma config de test. Les logs du Netopia, après redémarrage, montrent des "IPsec: rx: spi not found". Pour l'instant, je n'ai pas de solution, mais redémarrer le service sur Pfsense et faire tomber du même coup tous les autres tunnels ne me convient pas du tout…  :-\



  • Oui je confirme j'ai le même message dans les logs "IPsec: rx: spi not found" du nétopia …



  • Semble être reglé en supprimant les SAD existantes sur pfsense et en spécifiant dans le NETOPIA dans IP Profile Parameters du profil vpn dans remote tunnel endpoint l'adresse ip publique du pfsense (tans pis pour ceux qui n'ont pas d'adresses ip publiques fixes) ….


Log in to reply