PFblockerNG



  • Ok, really new at all this but I installed PFBlockerNG- devel and upon install got this failure. any help would be appreciated. I am really lost with this absolutely a NuBee

    Custom commands...
    Executing custom_php_install_command()...
    Downloading MaxMind GeoIP databases. This may take a minute...
    GeoLite2-Country.mmdb... cURL Error: 6. cURL Error: 6. cURL Error: 6. Failed!
    GeoLite2-Country-CSV.zip... cURL Error: 6. cURL Error: 6. cURL Error: 6. Failed!
    MaxMind download Failed! Fetching MaxMind archive from pfSense package repo...
    /tmp/countrycodes.tar.bz2 0 B 0 Bps
    Fetch done.
    Converting MaxMind GeoIP databases for pfBlockerNG.
    This may take a few minutes...
    Creating pfBlockerNG Continent PHP files...
    grep: /usr/local/share/GeoIP/cc/Antarctica_v4.txt: No such file or directory
    grep: /usr/local/share/GeoIP/cc/Antarctica_v6.txt: No such file or directory
    grep: /usr/local/share/GeoIP/cc/Proxy_and_Satellite_v4.txt: No such file or directory
    grep: /usr/local/share/GeoIP/cc/Proxy_and_Satellite_v6.txt: No such file or directory
    grep: /usr/local/share/GeoIP/cc/Top_Spammers_v4.info: No such file or directory
    grep: /usr/local/share/GeoIP/cc/Top_Spammers_v6.info: No such file or directory

    Also when I click to edit or configure GeoIp..the page says not found.
    pfblockerng/pfblockerng_Top_Spammers.php
    404 Not Found
    nginx



  • @Phantom_Stage said in PFblockerNG:

    Ok, really new at all this but I installed PFBlockerNG- devel and upon install got this failure. any help would be appreciated. I am really lost with this absolutely a NuBee

    Custom commands...
    Executing custom_php_install_command()...
    Downloading MaxMind GeoIP databases. This may take a minute...
    GeoLite2-Country.mmdb... cURL Error: 6. cURL Error: 6. cURL Error: 6. Failed!
    GeoLite2-Country-CSV.zip... cURL Error: 6. cURL Error: 6. cURL Error: 6. Failed!
    MaxMind download Failed! Fetching MaxMind archive from pfSense package repo...
    /tmp/countrycodes.tar.bz2 0 B 0 Bps
    Fetch done.
    Converting MaxMind GeoIP databases for pfBlockerNG.
    This may take a few minutes...
    Creating pfBlockerNG Continent PHP files...
    grep: /usr/local/share/GeoIP/cc/Antarctica_v4.txt: No such file or directory
    grep: /usr/local/share/GeoIP/cc/Antarctica_v6.txt: No such file or directory
    grep: /usr/local/share/GeoIP/cc/Proxy_and_Satellite_v4.txt: No such file or directory
    grep: /usr/local/share/GeoIP/cc/Proxy_and_Satellite_v6.txt: No such file or directory
    grep: /usr/local/share/GeoIP/cc/Top_Spammers_v4.info: No such file or directory
    grep: /usr/local/share/GeoIP/cc/Top_Spammers_v6.info: No such file or directory

    You need to get a MaxMind Registration, just follow the steps in this link to get the registration: https://forum.netgate.com/topic/149343/pfblockerng-maxmind-registration-required-to-continue-to-use-the-geoip-functionality/16.

    These steps should resolve the errors you are seeing. After you complete this if you still have questions, come back ask them.



  • @jdeloach Thanks I registered and got my License but don't see the latest version of pfBlockerNG 2.2.5_28 which is needed as I understand...only have 2.2.5_27 available...Will I have to uninstall the package and reinstall?


  • Moderator

    @Phantom_Stage
    No pfBlockerNG 2.2.5_28 should show in the pfSense package manager as an update.



  • @BBcan177 The package is not showing. for me still says 2.2.5_27... Is there a way to force the update?


  • Moderator

    @Phantom_Stage
    What version of pfSense? Try to run this command from the shell "pkg update -f"



  • @BBcan177 2.4.5-DEVELOPMENT (amd64)
    built on Thu Jan 02 07:20:28 EST 2020
    FreeBSD 11.3-STABLE


  • Moderator

    @Phantom_Stage
    I asked the devs and got this response:

    "If they are on snapshots (2.4.5 or 2.5.0) then the new packages are not immediately available, but will only show up when the next snapshot run happens."



  • @Phantom_Stage Thanks BBcan177...ran the "pkg update -f"...When is the snapshot scheduled do you know? Speaking as if i know what a snapshot is. closest thing I know to that is a Hockey Slapshot...lol.


  • Moderator



  • @BBcan177 Thanks again...! maybe I should have waited before going to 2.4.5-DEVELOPMENT just did that about two hours ago.



  • Much thanks to all who jumped in on this...! I was able to install the pfBlockerNG package today 2.2.5_28. Things are running well.


Log in to reply