Can't reach webgui, error took too long to respond



  • Hi, I installed pfsense on a spare PC of mine (Intel nics), installation was successful, and was able to assign interfaces and get their IP. However I cannot access the pfsense webgui.

    Everytime I try to connect to 192.168.1.1, I get a take too long to respond error message (tried chrome, edge).

    Tried switching cables, ports, changes switches and now I have the PC connected directly to the LAN port, but nothing seems to work. Trying to Ping the router or PC shows there is no traffic between them.

    Does anyone have any other troubleshooting methods or tips I can try? Is there another method to access the webgui? Thank you



  • Hi,

    You have the console access : what is shown in the main menu ?
    Keep this access open and accessible.
    Use a switch, and hook up a switch to the LAN port (not the WAN) - do the lights along the ports come up on both sides of the cable ?
    When hooking up, is there a messages shown on the console, in bold white mentioning that a connection on an interface comes UP.
    The shown interface device name corresponds with the NIC (LAN) port that you think the LAN port is ?
    Hook up a PC up to the switch.
    Just observe the notification area on your PC. Is there a message about a new network (will happen only the first time) ?
    Enter the console access on your PC (the cmd command prompt - or SSH access on a MAC).
    Use

    ipconfig /all
    

    for windows - ifconfig for MAC).
    Did your device received an IP/Gateway/DNS which corresponds with the pfSense settings ??
    And most important : you are not using some static IP settings on your PC ??

    Etc etc.
    Btw : nothing new here, these are all items on the basic network check-list that exists since ... 1985 ;)



  • @Gertjan just to double check, when you mean console, your talking about viewing the psfsense through a VGA display yes?

    Anyways I did check all the connections - 1) router to switch was green on both ends, 2) did not see any UP messages, 3) the interface name matches the actual port, 3) PC did detect new network, 4) yes IP/dns/gateway matched pfsense.

    Hmm, it seems the PC is using a static IP 10.0.0.101 - I did set it up within the original r7000, I had assumed it would be gone when I didn't use it anymore. Is there some way to nuke the config? Also I noticed my isp is also using the 192.168.1.1 for their modem - would this affect pfsense? Thanks


  • LAYER 8 Rebel Alliance

    You can't have 192.168.1.0/24 on WAN and LAN, this will cause trouble.
    Change your LAN to 192.168.2.0/24 for example via the VGA console and it should be fine.

    -Rico



  • @Rico my WAN is 192.168.1.4/24, while the LAN is 192.168.1.1/24. (And my isp seems to be using 192.168.1.1 for their own internet portal.) So your suggesting I change my LAN to 192.168.2.1? How about the WAN? All done through "set interface(s) IP address"? Is that correct? Thanks



  • @AndersKeiser said in Can't reach webgui, error took too long to respond:

    Hmm, it seems the PC is using a static IP 10.0.0.101 - I did set it up within the original r7000, I had assumed it would be gone when I didn't use it anymore. Is there some way to nuke the config?

    Properties of your network card, Select IPv4 and hit Properties.
    Undo your static settings ( Select "Obtain .... for IP and DNS) and Ok to the end.



  • @Gertjan sorry to bother you again, but I can't seems to nuke the static IP. I did as you suggested, but the network card was already set to obtain IP automatically. I tried using the command prompt to reset all connections, but ipconfig /all still states the IPv4 Address to be 192.168.1.101 (preferred). Originally I had assigned the static IP through the r7000, so it seems that is causing some sort of problem. Do you have any suggestions to fix this? Thank you



  • @AndersKeiser said in Can't reach webgui, error took too long to respond:

    but ipconfig /all still states the IPv4 Address to be 192.168.1.101 (preferred).

    This would be an IP given by pfSense (192.168.1.101 is in the DHCP pool you setup on pfSense).
    Btw : the IP is one thing.
    The Gateway should be 192.168.1.1 - as the DNS. As show by "ipconfig /all".

    As said above : setting LAN on 192.168.1.1/24 and WAN (by DHCP-client) obtaining an IP like 192.168.1.x/24 == same network as LAN is the best way to break things.

    If you can't reallocate your upstream router to, for example, to 192.168.2.1/24 then you can do so by changing the pfSense LAN to 192.168.2.1/24 - and adjusting the DHCP server on LAN.



  • @Gertjan and @Rico Thank you so very much for your help, finally got it working!

    I had to change the LAN IP address to 192.168.2.1 to get it working. So the cause of the issue seems to be the wan and lan being on the same network



  • @AndersKeiser said in Can't reach webgui, error took too long to respond:

    So the cause of the issue seems to be the wan and lan being on the same network

    A router want to (needs to !) route between different networks.
    If you have a network A and A on both side (like 192.168.1.0/24 on both sides) you should replace the router (pfSense) by a switch ;)


Log in to reply