Webserver hinter pfsense mit VIP und eigener domain - von extern ok - intern x



  • hi,

    habe hinter der pfsense einen webserver stehen der in seinem eigenen vlan hängt. Das Vlan hat nach aussen eine eigenständige virtuelle ip.
    Der Webserver ist dank der nat und firewall rules bereits von aussen über die domain die auf die VIP gedreht ist zu erreichen. Das heißt eigentlich ist nat und firewall technisch alles richtig eingestellt.

    Das Problem ist das in dem VLAn in dem sich der server befindet noch 2 weitere client rechner hängen. Diese wollen den Webserver auch über seine öffentliche Domain erreichen. Das Problem ist das das nicht geht. Die Pfsense kann eine Anfrage auf die Domain offenbar nicht richtig verarbeiten denn ein:

    tracert web.xxxx.de
    1      1ms      1ms      2ms      62.159.xx.xx (öffentliche IP)

    dann ist schon schluss.

    und wie gesagt von extern (z.b anderer dsl anschluss) geht das aufrufen der domain problemlos nur von intern nicht

    was muss da beachten das das läuft

    SOLVED-WATCH LAST POST GELÖST-LETZTEN POST ANSCHAUEN



  • hi … ich weiss nicht ob das mit deinen VLANs etc. nicht vielleicht noch ein anderes Problem mit reinspielt. Aber normalerweise lüppt das, wenn unter SYSTEM->ADVANCED bei "Disables the automatic creation of NAT redirect rules ..." KEIN Häkchen gesetzt ist.



  • ja also irgendwas ist merkwürdig denn von extern wie gesagt funktioniert das nat und das portforwarding.
    von intern wird die domain auch aufgelöst und zwar eigentlich auch auf korrektem wege denn sie endet wie auch von extern auf der öffentlichen (virtuellen IP für den server). allerdings scheinen die nat und firewall rules für das von intern aufrufen der domain nicht zu greifen.

    nat rules sind auf das wan interface auf die entsprechende vip angewendet



  • das interessante ist wenn ich im dns forwarder die domain auf die interne ip adresse des servers lenke gehen auch die anfragen von intern auf die domain. das ist aber nicht sinn und zweck. denn hinter der domain steht eigentlich nciht nur ein server sondern mehrere server die auf entsprechende ports durch das portforwarding angesprochen werden. aber mit der dns forwarder regel kann ich ja die domain nur auf eine ip forwarden. das ist schlecht

    @Eml der genannte Hacken der nicht gesetzt werden darf ist nicht gesetzt
    wenn ich die domain aufrufe aus dem internen netz kommt ne leere weiße seite. das ist aber nicht die vom webserver. da muss noch irgendwas andere fehlen. ich nehme an die pfsense allowed das portforwarding nicht wenn ich die domain von intern aufrufe



  • Es läuft - Firmware Upgrade auf die 1.2.3 RC1 hat den Fehler behoben. In der Version die ich hatte war das mit dem
    "Disables the automatic creation of NAT redirect rules …"
    noch ein Bug und funktionierte nicht


Log in to reply