lokale DNS-Auflösung an der PFSense



  • Hallo zusammen,

    was mir die Tage immer wieder aufgefallen ist ist die Tatsache dass die DNS-Auflösung direkt auf der PFSense ins lokale LAN nicht funktioniert.

    Meine PFSense hat auf dem LAN-Interface die 192.168.24.254 und den FQH gateway01.intern.local

    Im LAN befindet sich der lokale DNS-Server (192.168.24.5 / srv01.intern.local).

    In den allg. Einstellungen der PFSense ist dieser Host- / Domän - Name angegeben sowie die IP des DNS-Server gesetzt. Eine Shell auf der PFSense zeigt auch:

    [2.4.4-RELEASE][root@gateway01.intern.local]/root: cat /etc/resolv.conf 
    nameserver 127.0.0.1
    nameserver 8.8.8.8
    nameserver 192.168.24.5
    search intern.local
    

    jedoch funktioniert ein Ping von der PFSense (Shell) auf z.B. srv01.intern.local nicht. Was mache ich falsch?

    Viele Grüße
    pixel24



  • Lösche 8.8.8.8. Der kann ja deine internen Namen nicht auflösen.

    Einen öffentlichen DNS Server kannst du am lokalen angeben, um Anfragen, die er selbst nicht beantworten kann, dahin weiterzuleiten.

    Grüße



  • @viragomann said in lokale DNS-Auflösung an der PFSense:

    Lösche 8.8.8.8. Der kann ja deine internen Namen nicht auflösen.

    Dieser Eintrag (8.8.8.8) verschwindet aus der resolv.conf wenn ich in den Algg. Einstellungen:

    DNS-Server Überschreibung

    deaktiviere. Ein Ping auf srv01.intern.local funktioniert aber trotzdem nicht.



  • DNS Service neu gestartet?

    Warum Ping? Das setzt voraus, dass der Server auf Ping antwortet.
    Mach einfach einen DNS-Lookup, um das Problem einzugrenzen. Bspw. im GUI: Diagnostics > DNS Lookup



  • @viragomann said in lokale DNS-Auflösung an der PFSense:

    DNS Service neu gestartet?

    jetzt ja

    @viragomann said in lokale DNS-Auflösung an der PFSense:

    Warum Ping? Das setzt voraus, dass der Server auf Ping antwortet.

    Ja, tut er ... also bei allen anderen Clients

    @viragomann said in lokale DNS-Auflösung an der PFSense:

    Mach einfach einen DNS-Lookup, um das Problem einzugrenzen. Bspw. im GUI: Diagnostics > DNS Lookup

    Ja, das scheitert genauso. Hatte in der Shell schon mit nslookup getestet. Was auch den lokalen Namen nicht auflösen kann. Gebe ich, in der Sell nslookup ein und spezifiziere den DNS-Server:

    [2.4.4-RELEASE][root@gateway01.intern.local]/root: nslookup
    > srv01.intern.local
    Server:		127.0.0.1
    Address:	127.0.0.1#53
    
    ** server can't find srv01.intern.local: NXDOMAIN
    > server 192.168.24.5
    Default server: 192.168.24.5
    Address: 192.168.24.5#53
    > srv01.intern.local
    Server:		192.168.24.5
    Address:	192.168.24.5#53
    
    Name:	srv01.intern.local
    Address: 192.168.24.5
    >
    

    Er verwendet den eingestellten DNS überhaupt nicht.



  • Ist etwa in General Setup der Haken bei "Disable DNS Forwarder" gesetzt.

    Oder, wenn du den Resolver verwendest, muss das Interface, an dem der DNS Server hängt, bei "Outgoing Network Interfaces" ausgewählt sein, falls die Option nicht auf "All" gesetzt ist.



  • @viragomann said in lokale DNS-Auflösung an der PFSense:

    Ist etwa in General Setup der Haken bei "Disable DNS Forwarder" gesetzt.

    Nein, Haken ist/war nicht gesetzt

    @viragomann said in lokale DNS-Auflösung an der PFSense:

    Oder, wenn du den Resolver verwendest, muss das Interface, an dem der DNS Server hängt, bei "Outgoing Network Interfaces" ausgewählt sein, falls die Option nicht auf "All" gesetzt ist.

    Wo finde ich diese Einstellung? Unter Firewall?



  • @pixel24 said in lokale DNS-Auflösung an der PFSense:

    Wo finde ich diese Einstellung? Unter Firewall?

    Services > DNS Resolver > General Settings

    Vorausgesetzt, du verwendest den Resolver, was aber Standard ist.



  • Der ist aktiv, da habe ich nichts verändert:
    bdc78176-e30f-424c-8f4f-9216a24af85c-grafik.png


Log in to reply